Page MenuHomePhabricator

CX2: Repeated reference added using a different number on each paragraph
Closed, ResolvedPublic

Description

Testing CX2 in production by translating "Atazanavir" from English to Spanish (trying to reproduce T195665), the references for the first two paragraphs present a strange behaviour when added to the translation:

  • In the source text both paragraphs use the same reference in multiple places (notice the "[1]" in both paragraphs). However, when added to the translation, the references are rendered as if they were different ("[1]" in the first paragraph, and "[2]" in the second).
  • When selecting the references in the translaiton, the reference card is not shown, and double-clicking on any reference shows the reference dialog empty.

Note that these issues are no longer present in the translaiton if you exit the translation editor and load the translation again.

The expected behaviour would be for references in the translation to use the same numbers as the source text, and its contents being visible (as a card and in the editing dialog).

After clicking on any reference:


Related ticket: T113564: Automatically merge duplicate references in ContentTranslation

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 4 2018, 9:18 AM
Pginer-WMF triaged this task as Medium priority.Jun 4 2018, 9:18 AM
Pginer-WMF moved this task from Needs Triage to CX2 on the ContentTranslation board.
Pginer-WMF updated the task description. (Show Details)Jun 4 2018, 9:31 AM
Vvjjkkii renamed this task from CX2: Repeated reference added using a different number on each paragraph to fpbaaaaaaa.Jul 1 2018, 1:06 AM
Vvjjkkii raised the priority of this task from Medium to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from fpbaaaaaaa to CX2: Repeated reference added using a different number on each paragraph.Jul 2 2018, 7:48 AM
CommunityTechBot lowered the priority of this task from High to Medium.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.
Pginer-WMF updated the task description. (Show Details)Aug 1 2018, 7:35 AM

As we improve the support for duplicated references, we may want to check if T113564: Automatically merge duplicate references in ContentTranslation gets resolved too.

The issue seems to be resolved. See two screenshots

Pginer-WMF closed this task as Resolved.Aug 7 2018, 2:32 PM
Pginer-WMF claimed this task.

The issue seems to be resolved. See two screenshots

I checked this in production for version 2, and it works as expected: all instances of [1], rendered as "[1]".

(when testing there were still issues with reference content being duplicate since changes from T199320 may have not been deployed yet into production)