Page MenuHomePhabricator

CX2: References content is duplicated multiple times when adapted
Closed, ResolvedPublic

Description

When translating the article "Achilles tendon rupture" from English to Spanish in production, the first paragraph gets added to the translation, but the contents of the first reference appear duplicated, as shown below:

In the source article, such reference is added as <ref name=Fer2016/> which is an alias for a reference containing the info some paragraphs below:

<ref name=Fer2016>{{cite book |last1=Ferri |first1=Fred F. |title=Ferri's Clinical Advisor 2016 E-Book: 5 Books in 1 |date=2015 |publisher=Elsevier Health Sciences |isbn=9780323378222 |page=19 |url=https://books.google.co.uk/books?id=bbLSCQAAQBAJ&pg=PA19 |language=en}}</ref>

After the adaptation, the result includes:

  • The cite book template with the original information.
  • A plain text version of the automatic translation of the same content.
  • Two more copies of the cite book template with the original info.

The expected result would be to have only one copy of the cite book template, where some parameters can be translated through the machine translation service selected. Deciding which parameters to translate and how to control it may require more thought (T197688), but we want to avoid the duplicates and templates becoming plain text.

The example is based on feedback provided here. This may be related to other issues caused by the way to process references that are shared in multiple paragraphs (T196136, T191011).

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 11 2018, 12:17 PM
Pginer-WMF triaged this task as Normal priority.Jul 11 2018, 12:18 PM
Pginer-WMF updated the task description. (Show Details)
Pginer-WMF moved this task from Needs Triage to CX2 on the ContentTranslation board.
santhosh updated the task description. (Show Details)Jul 26 2018, 6:39 AM

Change 449167 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/services/cxserver@master] WIP: Support adapting Cite web,journal,book.. templates in references

https://gerrit.wikimedia.org/r/449167

santhosh claimed this task.Jul 31 2018, 8:55 AM

Change 449167 merged by jenkins-bot:
[mediawiki/services/cxserver@master] Support adapting Cite web, journal, book.. templates in references

https://gerrit.wikimedia.org/r/449167

Petar.petkovic moved this task from In Review to QA on the Language-2018-July-September board.
Petar.petkovic removed a subscriber: gerritbot.

Mentioned in SAL (#wikimedia-operations) [2018-08-08T06:17:16Z] <kartik@deploy1001> Finished deploy [cxserver/deploy@6a0cab1]: Update cxserver to 951fdba (T199308, T199512, T199320, T200665, T200453, T106437) (duration: 03m 32s)

Etonkovidova closed this task as Resolved.Sep 7 2018, 1:05 AM
Etonkovidova added a subscriber: Etonkovidova.

Checked in CX2 - only one copy of book cite template is displayed

Petar.petkovic removed a subscriber: Stashbot.