Page MenuHomePhabricator

Update Wikimedia CH landing page redirects
Closed, ResolvedPublic1 Estimated Story Points

Description

Donatewiki currently redirects users in Switzerland to pages on wmfwiki like https://wikimediafoundation.org/wiki/WMFJA1/CH. These pages will be going away soon, and Wikimedia CH have long hosted their own landing pages (which have already been used to receive traffic from banners).

We should update donatewiki to redirect Swiss users to the following pages. I confirmed this with @Ilario from the chapter.

I found some documentation at https://wikitech.wikimedia.org/wiki/Donate.wikimedia.org#Chapter_Redirects but it was last updated in 2013 so may not be current.

Event Timeline

Pcoombe created this task.Jun 4 2018, 7:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 4 2018, 7:28 PM
DStrine added a subscriber: DStrine.Jun 5 2018, 8:27 PM

@Pcoombe do you need any help with this? Is this your own task?

Pcoombe added a comment.EditedJun 6 2018, 11:49 AM

fr-tech will need to do this. I believe it's part of the FundraiserLandingPage configuration.

Vvjjkkii renamed this task from Update Wikimedia CH landing page redirects to onbaaaaaaa.Jul 1 2018, 1:05 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from onbaaaaaaa to Update Wikimedia CH landing page redirects.Jul 1 2018, 9:58 PM
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.

@DStrine Just to note this will need to be done before the new WMF site launches and the current one is archived (currently scheduled for 30 July). Let me know if there's any way I can help.

Change 445724 had a related patch set uploaded (by Ejegg; owner: Ejegg):
[mediawiki/extensions/FundraiserLandingPage@master] Update redirects to CH chapter donate page

https://gerrit.wikimedia.org/r/445724

Ejegg added a subscriber: Ejegg.Jul 13 2018, 8:58 PM

@Pcoombe heh, looks like that 2013 documentation was still accurate. It's a horrible hack (putting URLs in i18n messages) but it meant we could add different URLs for different languages without changing the extension's logic.

Ejegg claimed this task.Jul 13 2018, 8:58 PM
Ejegg triaged this task as Medium priority.
Ejegg set the point value for this task to 1.

Change 445724 merged by jenkins-bot:
[mediawiki/extensions/FundraiserLandingPage@master] Update redirects to CH chapter donate page

https://gerrit.wikimedia.org/r/445724

Pcoombe closed this task as Resolved.Jul 20 2018, 11:15 AM

I tested this and found it was only working in English. Turns out the translation updater bot removed the other messages, probably because they are marked as not for translation (and should definitely remain so, or anyone with translatewiki access could redirect people in these countries off to their choice of url!)

However I realised that we can just edit the local MediaWiki namespace messages on donatewiki instead, which is actually what was done before for the old landing pages. This is done now, and everything appears to be working.

Thanks, and apologies for the confusion!