Page MenuHomePhabricator

gerrit: run "LocalUsernamesToLowerCase" utility on gerrit host to fix mixed case usernames in gerrit's accounts db
Closed, InvalidPublic

Description

After much debugging I've determined that our gerrit instance has some user accounts stored in mixed case. That would be acceptable if it weren't for the fact that we have the configuration option
ldap.localUsernameToLowerCase specified to force logins to use all lower-case.

The result of this is that gerrit creates duplicate user accounts for anyone who has their account stored in mixed case. Then, seeing the duplicate account record, gerrit refuses to let them log in. This is affecting at least Kaldari I tried to correct one instance of this bug (for user @kaldari) by editing the username via gerrit's rest api, however, gerrit doesn't allow me to edit usernames via api. The only other way I know of to correct the problem is by running the conversion utility provided by gerrit and described here

Event Timeline

mmodell renamed this task from gerrit: run "LocalUsernamesToLowerCase" utility on gerrir host to fix mixed case usernames in gerrit's accounts db to gerrit: run "LocalUsernamesToLowerCase" utility on gerrit host to fix mixed case usernames in gerrit's accounts db.Jun 14 2018, 6:40 PM
mmodell triaged this task as High priority.
mmodell created this task.

https://wiki.linaro.org/Platform/Systems/Gerrit/DupAccounts discusses how to delete dupe accounts with the old sql accounts db.

from the LocalUsernamesToLowerCase docs: "The program will produce errors if there are accounts that have the same local username, but with different case. In this case the local username for these accounts is not converted to lower case."

I could've sworn we ran this after we changed that setting...

mmodell closed this task as Invalid.Jun 18 2018, 4:28 PM

@demon: that's probably true. I think the dupes actually got introduced more recently due to some bug in gerrit.

Unfortunately running the conversion script won't resolve anything so this task is invalid.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptJun 18 2018, 4:28 PM
demon added a comment.Jun 19 2018, 8:00 AM

I re-ran it. It dies with an exception anyway :P

Vvjjkkii renamed this task from gerrit: run "LocalUsernamesToLowerCase" utility on gerrit host to fix mixed case usernames in gerrit's accounts db to yzaaaaaaaa.Jul 1 2018, 1:03 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from yzaaaaaaaa to gerrit: run "LocalUsernamesToLowerCase" utility on gerrit host to fix mixed case usernames in gerrit's accounts db.Jul 2 2018, 7:26 AM
CommunityTechBot closed this task as Invalid.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.