Page MenuHomePhabricator

Use icons with text for actions etc at higher resolutions so people don't get confused when they switch to icons only at lower ones
Closed, ResolvedPublic

Description

Currently cactions elements are text-only at higher resolutions, and icons-only at lower. This transition can unnecessarily surprise and confuse users:

  • At high resolutions, expected visual handles disappear
  • At low resolutions, visual handles do not have established connection to what they represent

Surprising:

Event Timeline

Paladox created this task.Jun 16 2018, 10:15 PM
Paladox updated the task description. (Show Details)
Paladox updated the task description. (Show Details)Jun 16 2018, 10:18 PM

What's the difference between expected and actual behaviour, again?

@Isarra on the top bar you see "Navigation" and all along there other text too, those are icons if you spread the browser or make it small.

Izno added a subscriber: Izno.Jun 17 2018, 1:16 PM

This is intended behavior. There is an intermediate size between "icons" and "2 column view".

This is intended behavior. There is an intermediate size between "icons" and "2 column view".

But if you make it a bit bigger it has icons and when you make it smaller the mobile display kicks in so icons show.

Vvjjkkii renamed this task from Text shown instead of icons at certain browser sizes to nsaaaaaaaa.Jul 1 2018, 1:03 AM
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
CommunityTechBot renamed this task from nsaaaaaaaa to Text shown instead of icons at certain browser sizes.Jul 2 2018, 4:45 AM
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
Isarra renamed this task from Text shown instead of icons at certain browser sizes to Use icons with text for cactions etc at higher resolutions so people don't get confused when they switch to icons only at lower ones.Aug 16 2019, 5:36 PM
Isarra updated the task description. (Show Details)

Repurposing; this does seem to have hit on an important UX concern.

Aklapper renamed this task from Use icons with text for cactions etc at higher resolutions so people don't get confused when they switch to icons only at lower ones to Use icons with text for actions etc at higher resolutions so people don't get confused when they switch to icons only at lower ones.Aug 20 2019, 11:36 PM

Change 531724 had a related patch set uploaded (by Isarra; owner: Isarra):
[mediawiki/skins/Timeless@master] Add icons to desktop cactions and overhaul icon alignment and usage throughout

https://gerrit.wikimedia.org/r/531724

Change 531724 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] Add icons to desktop cactions and overhaul icon alignment and usage throughout

https://gerrit.wikimedia.org/r/531724

Isarra closed this task as Resolved.Aug 26 2019, 1:29 AM
Isarra claimed this task.