Page MenuHomePhabricator

Toolbar menu positioning broken when zoom level > 100%
Closed, ResolvedPublic

Description

Event Timeline

Esanders created this task.Jul 16 2018, 9:49 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 16 2018, 9:49 PM
Esanders renamed this task from Toolbar menu positioning broken on en.wiki to Toolbar menu positioning broken when zoom level > 100%.Jul 16 2018, 9:52 PM
Esanders updated the task description. (Show Details)

For me (in Firefox) the menu is positioned correctly in any zoom level, but it reminds me of T194120: Layout of edit mode switcher in old wikitext editor broken in Monobook skin (though that happens in a completely different situation, so it might be completely unrelated).

Maybe just Chrome only.

I can reproduce in Vivaldi, but only if I first zoom in, and then load a new page. It doesn't happen if the page was at 100% zoom when originally loaded, even if zoomed afterwards. It also happens for zoom levels < 100%. Firefox seems unaffected.

matmarex closed this task as Resolved.Sep 7 2018, 4:34 PM
matmarex claimed this task.
matmarex added a subscriber: matmarex.

I debugged this today after seeing T203720, and I'm happy to report that it was caused by a jQuery bug (https://github.com/jquery/jquery/issues/3808) and has been just fixed by rMWdbbb45eadb18: Update jQuery from v3.2.1 to v3.3.1.

@Esanders @Schnark The change is live on the Beta Cluster, so you can compare that to production wikis to confirm.

Unfortunately T194120 looks like a different issue, because I can still reproduce that. I didn't try to debug why that one happens.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSep 7 2018, 4:34 PM