Page MenuHomePhabricator

Impossibility to use Ping project on projects over 50 participants
Closed, DeclinedPublic

Description

When trying to ping 3 different projects on a property proposal (about copyright), I discovered that it was impossible, because 2 of those 3 projects have over 50 participants (Books and sum of all paintings).

This is specifically problematic because it concerns succesfull projects, because most participants will never be conscious of this limit, and the notifications will never be done, while the message "project participants notified" is displayed, thus leading to very bad dialog on big projects and it is also very difficult to notify everybody individually.

It would be nice if the upper limit of 50 was removed when ping is made using {{ping project}}, especially when the user adding it is member of the project. This limit makes this template useless precisely where it would be the most useful.

Discussions:
Project chat: impossibility to ping succesful projects ?
WikiProject Books: Too many names to ping

Event Timeline

Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 25 2018, 4:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Related: T108293.

Also:

Originally, the limit was 300. That was then reduced to 100, and then to 20. The limit of 20 has been getting regular complaints, so they're raising it to 50. Suggestions/alternatives welcome. :)

PKM added a subscriber: PKM.Jul 25 2018, 6:27 PM

+1 This is urgently needed.

Jklamo added a subscriber: Jklamo.Jul 26 2018, 12:13 PM
Wostr added a subscriber: Wostr.Jul 29 2018, 6:22 AM

{{Ping project}} uses a Hidden Structure which causes issues for bots, web scrapers, and screen readers. The proper fix is to add the functionality to Echo.

Dispenser updated the task description. (Show Details)Aug 19 2018, 10:15 PM

I really don't think Echo Notifications are the right solution to this problem. If you need to message more than 50 people at once, you should probably use a mailing list. There's also the Newsletter extension, which is installed on Mediawiki.org and could be installed on Wikidata as well. If neither of those solutions will work, I think we may need to create some new software specifically to address this use case (that is separate from mention notifications). The fact that {{ping project}} uses hidden content is also problematic. Rather than expanding this hack, maybe we need something different.

Regardless, when we had higher ping thresholds before, we got lots of complaints about misuse. The current 50 person threshold is a compromise that was reached over a long period of trial and error and I don't think significantly changing it is a good idea.

Hsarrazin added a comment.EditedAug 21 2018, 7:06 PM

The problem is to ping the members of a specific project on wikidata, for discussions outside the project, (on property discussion, on the project chat, etc.), because all members of the project are potentially concerned by the discussion.
A mailing list or a newsletter would be no use at all for this purpose.

I don't understand at all how 'ping project' template works : I only see that it becomes useless precisely when it would the most useful :(

@Hsarrazin: Typically on other wikis, the way to notify a project of a discussion is to post on the project's talk page.

We are considering this for Growth team maintenance work.

MMiller_WMF edited projects, added Growth-Team; removed Growth-Team (Current Sprint).

@JTannerWMF -- this task is supposed to be in our "Revisit" column, but I can't figure out how to get it there. Could you please help?

[offtopic:] @MMiller_WMF: Clicking in the upper right corner of https://phabricator.wikimedia.org/tag/growth-team/ and then " Manage Workboard" and then "Revisit", you can see that the "Revisit" column was hidden: https://phabricator.wikimedia.org/project/board/1114/column/12067/

@Aklapper - Somehow this task is in 2 different columns on the same board simultaneously. I can't find any mechanism to remove a task from a column, but not a workboard. Any advice?

Aklapper moved this task from Revisit to Upcoming Work on the Growth-Team board.Sep 18 2018, 10:52 PM

@kaldari: Workboard visualization out of sync, I guess... I tried to drag it from "Revisit" to the "Upcoming Work" column and got Unhandled Exception: Unable to find object "PHID-TASK-bqrlttxcm5qknkucjucy" in column "PHID-PCOL-vaw55qipj2ivbyj6koqk" on board "PHID-PROJ-m5xekuzpcucwdjim2onx. Dragging the other way round (from Upcoming to Revisit) and then back (from Revisit to Upcoming) removed the duplicate. Feel free to file a bug report under Phabricator.

Trizek-WMF moved this task from Upcoming Work to Revisit on the Growth-Team board.Sep 19 2018, 1:49 PM
MMiller_WMF closed this task as Declined.Sep 19 2018, 4:40 PM

We have decided to decline this task after discussing on our team. The reason is that this pinging limit has been the subject of debate for a while, and has moved around over time -- it has been up to 300 and as low as 20. The limit is there for good reasons, and the workarounds that exist seem to do a good job of helping make sure that people who really need to ping many users can do it. For the specific "ping project" use-case, we recommend that the bot behind the template be modified to ping people in batches of 50.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptSep 19 2018, 4:40 PM