Page MenuHomePhabricator

Dup entries / cards when displaying results for patches submitted
Closed, ResolvedPublic

Description

A notice about duplicate cards when information is updated in the .json file that acts as our database, see for example; https://tools.wmflabs.org/awmd-stats/month/2018-07. When a user submits a patch, it's tracked and when it's merged and the page is refreshed, it makes a new entry instead of updating the currently from "NEW" to "MERGED" and as a result, it creates a duplicate of the same result set.

Event Timeline

D3r1ck01 triaged this task as Normal priority.Aug 8 2018, 9:45 PM
D3r1ck01 created this task.
D3r1ck01 added a comment.EditedAug 8 2018, 9:51 PM

This currently happens in production, see here: http://tools.wmflabs.org/awmd-stats/

Qgil removed a subscriber: Qgil.Aug 9 2018, 11:32 AM
D3r1ck01 closed this task as Resolved.Aug 14 2018, 11:38 AM
D3r1ck01 assigned this task to samuelguebo.

Thanks Samuel for fixing this issue. This can now be marked as resolved, check here: https://tools.wmflabs.org/awmd-stats/refresh/2018-08.

D3r1ck01 reopened this task as Open.Aug 14 2018, 12:38 PM

Hello @samuelguebo, I'm reopening this due to 1 reason. The grouping works fine but the status of the patch is not updated. So after grouping, patches with status "NEW" still remain "NEW" even if it's been merged. Maybe you can have a look at this? :)

Hi @D3r1ck01, I suspect something, but can you provide me with a link so I can witness this situation?

Thanks for elaborating, mate. Kindly review the PR: https://github.com/samuelguebo/awmd-stats/pull/34

samuelguebo closed this task as Resolved.Aug 14 2018, 2:43 PM