Page MenuHomePhabricator

Technical Collaboration annual plan FY2017-18
Closed, ResolvedPublic

Description

NOTE: All this is a rough draft -- many things may change at this point.

This is where we track progress about the Technical Collaboration participation in the Wikimedia Foundation Annual Plan FY2017-18

We will be involved in several cross-team programs:

  • Technical collaboration with Wikimedia communities (Confirmed. TC lead: @Elitre)
  • Structured data (Confirmed. TC lead: @Elitre)
  • MediaWiki 3rd party support (Proposed. TC lead: @srishakatux)
  • ... More?

We will also have our own programs:

All these are proposals at this point. The Developer-Wishlist (2017) will help prioritizing these ideas.

There are other big items that are expected to be reflected in the annual plan, even if they might not become programs themselves:

Event Timeline

Qgil created this task.Dec 12 2016, 8:23 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 12 2016, 8:23 PM
Boshomi added a subscriber: Boshomi.Jan 1 2017, 9:58 PM
Zppix added a subscriber: Zppix.Jan 25 2017, 9:32 AM
Qgil raised the priority of this task from Low to High.Feb 2 2017, 8:12 AM
Qgil updated the task description. (Show Details)Feb 2 2017, 5:27 PM
Qgil added subscribers: srishakatux, Elitre.
Qgil updated the task description. (Show Details)Feb 2 2017, 6:00 PM
Qgil lowered the priority of this task from High to Normal.Mar 7 2017, 12:02 PM

Yesterday we presented a first draft of our proposals and budget to Maggie. Now the review process starts.

I want to publish this draft but at the same time I want to respect the WMF annual process. I have asked.

Lowering priority because the work now is expected to be based on reactions to feedback, questions, requests.

Qgil closed this task as Resolved.Jun 27 2017, 8:40 AM

I am considering the review of our annual plan completed. I will post updated URLs here as soon as the entire WMF annual plan is moved out of draft in Meta.

I think Technical Collaboration is in a much better place now with our two programs! Thank you to all contributors.