Page MenuHomePhabricator

View content and edit content overlaid on top of each other (?) on mobile visual editor
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. On your mobile device, go to https://en.m.wikipedia.org/wiki/Stockport
  2. Open the mobile visual editor
  3. Scroll whilst the page is loading

Expected:

  • Read content, or edit content, or a loading indicator should be shown

Actual:

  • Content is shown overlapping other content (I think it's edit and read content?)

Event Timeline

Deskana created this task.Aug 22 2018, 11:41 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 22 2018, 11:41 AM
Deskana triaged this task as Medium priority.Aug 22 2018, 11:41 AM
Deskana moved this task from To Triage to Up next on the VisualEditor board.
Deskana updated the task description. (Show Details)Aug 22 2018, 4:13 PM
Deskana moved this task from Up next to Current work on the VisualEditor board.Aug 22 2018, 5:25 PM
Deskana edited projects, added VisualEditor (Current work); removed VisualEditor.
Esanders added a subscriber: Esanders.EditedAug 22 2018, 6:59 PM

@Deskana: I'm not seeing this on Android, even with 4x CPU throttling...

It could be related to showing the editor too early, which I'm looking in to in T202513

@Deskana: I'm not seeing this on Android, even with 4x CPU throttling...

It could be related to showing the editor too early, which I'm looking in to in T202513

Hmm. My Android device is a Nexus 6 and is not especially old. The page stayed this way for several seconds, and was otherwise responsive during that period. I don't know what to suggest.

Change 454807 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/MobileFrontend@master] Add 'content' class to surface before it is shown

https://gerrit.wikimedia.org/r/454807

Esanders moved this task from Incoming to In progress on the VisualEditor (Current work) board.

I'll separate my fix into a new issue, not sure if they're the same yet: T202987

Change 455826 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/MobileFrontend@master] Guard against VE overlay being shown twice

https://gerrit.wikimedia.org/r/455826

Change 455826 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Guard against VE overlay being shown twice

https://gerrit.wikimedia.org/r/455826

Deskana closed this task as Resolved.Sep 27 2018, 1:49 PM

I can't reproduce this now, so I guess we have to assume that this is fixed until we prove otherwise.