Page MenuHomePhabricator

Proofreading is broken on Special:Translate: infinite spinner and JavaScript errors
Closed, ResolvedPublic

Description

Hi all,

on translatewiki, message "Chargement des messages… " is stuck in an infinite loop with the turning circle and without giving hand back with the list of possible messages to reread (... may be there are none). I must abort the page. Translations are possible from the home page of translatewiki in the normal way, leading to 'Reread' button when there are no more translations (this is ok). This wait was not observed before (... may be because there were always messages left to reread).

https://translatewiki.net/wiki/Special:Translate?action=proofread&group=%21recent&language=fr&filter=translated%7C%21reviewer%3A15345%7C%21last-translator%3A15345

The similar lock situation observed on mediawiki:

https://www.mediawiki.org/w/index.php?title=Special:Translate&group=page-Help%3AExtension%3ATranslate%2FPage+translation+example&action=proofread&filter=translated%7C%21reviewer%3A887141%7C%21last-translator%3A887141&language=fr

Details

Related Gerrit Patches:
mediawiki/extensions/Translate : masterUnbreak proofreading

Event Timeline

Wladek92 created this task.Sep 4 2018, 7:19 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 4 2018, 7:19 AM
Uncaught TypeError: reviewers.indexOf is not a function
    at Proofread.render (ext.translate.proofread.js?53806:87)
    at Proofread.init (ext.translate.proofread.js?53806:40)
    at new Proofread (ext.translate.proofread.js?53806:28)
    at HTMLDivElement.<anonymous> (ext.translate.proofread.js?53806:271)
    at Function.each (jquery.js?09dd6:362)
    at jQuery.fn.init.each (jquery.js?09dd6:157)
    at jQuery.fn.init.$.fn.proofread (ext.translate.proofread.js?53806:265)
    at MessageTable.addProofread (ext.translate.messagetable.js?b09e3:249)
    at MessageTable.add (ext.translate.messagetable.js?b09e3:132)
    at Object.<anonymous> (ext.translate.messagetable.js?b09e3:486)

About half of the time I also see

Uncaught TypeError: $message.proofread is not a function
    at MessageTable.addProofread (ext.translate.messagetable.js?b09e3:249)
    at MessageTable.add (ext.translate.messagetable.js?b09e3:132)
    at Object.<anonymous> (ext.translate.messagetable.js?b09e3:486)
    at Function.each (jquery.js?09dd6:362)
    at ext.translate.messagetable.js?b09e3:484
    at fire (jquery.js?09dd6:3317)
    at Object.fireWith [as resolveWith] (jquery.js?09dd6:3447)
    at Object.deferred.(/wiki/anonymous function) [as resolve] (https://translatewiki.net/w/resources/lib/jquery/jquery.js?09dd6:3778:36)
    at Object.<anonymous> (index.js?68ce7:276)
    at fire (jquery.js?09dd6:3317)

Change 457830 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/Translate@master] Unbreak proofreading

https://gerrit.wikimedia.org/r/457830

Nikerabbit renamed this task from Reread impossible : no response from translatewiki/mediawiki when trying to review translations from other users to Proofreading is broken on Special:Translate: infinite spinner and JavaScript errors.Sep 4 2018, 8:11 AM
Nikerabbit claimed this task.
Nikerabbit triaged this task as Unbreak Now! priority.
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptSep 4 2018, 8:11 AM

very reactive; super Nike !

Change 457830 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] Unbreak proofreading

https://gerrit.wikimedia.org/r/457830

Petar.petkovic moved this task from In Review to QA on the Language-2018-July-September board.
Petar.petkovic removed a subscriber: gerritbot.

@Nikerabbit this is not only confirmable on twn, but also meta-wiki and mw.org, so why not using MediaWiki-extensions-Translate instead?

For anyone wondering, there are two separate issues. My patch fixes both. Only one of the issue is observable on Wikimedia production. I am not planning a SWAT deployment, hoping the MediaWiki train will run on schedule soon.

Sounds good now from user'point of view. May be conditions are not the same. Thanks all.

Etonkovidova closed this task as Resolved.Sep 7 2018, 10:38 PM
Etonkovidova added a subscriber: Etonkovidova.

Checked on translatewiki.net and mediawiki (wmf.20) - all looks normal.