Create punjabi.wikimedia.org for Punjabi Wikimedians User Group
Closed, ResolvedPublic

Description

We need a separate wiki for Punjabi Wikimedians UG. Discussion is here

"Visibility": fishbowl
Sitename: Punjabi Wikimedians
Logo: https://commons.wikimedia.org/wiki/File:Punjabi_Wikimedians_User_Group_logo_-_variation_1.svg
Extensions: Translate
Domain: punjabi.wikimedia.org
Dbname: punjabiwikimedia

Related Objects

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 17 2018, 8:45 AM
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptSep 17 2018, 8:55 AM

Discussion on meta-wiki: here

MarcoAurelio changed the task status from Open to Stalled.Sep 17 2018, 8:59 AM
MarcoAurelio added a subscriber: MarcoAurelio.

While we're on Datacenter-Switchover-2018 we ain't allowed to create new wikis. In addition, data such as the type of wiki you want (public, private or fishbowl) among other things are missing here. Thanks.

Well, we can prepare config patches and let sysadmins to create wiki later (when feasible). Yeah, please give us at least following details

  • "Visibility": Public, private, fishbowl
  • Sitename
  • Logo
  • Do you want any specific extensions (like Translate)?
  • How should the wiki domain look like: The format is <something>.wikimedia.org for those wikis, maybe <langcode>.wikimedia.org, but I don't know the code for Punjabi.
  • Maybe other things, I just don't remember them all. Will ask when necessary.
Urbanecm moved this task from Backlog to Own projects on the User-Urbanecm board.Sep 18 2018, 2:49 PM
Urbanecm moved this task from Own projects to Blocked on others on the User-Urbanecm board.
Base added a subscriber: Base.Sep 19 2018, 5:12 PM

The ISO 639-1 code for Punjabi is obviously pa, the respective Wikipedia is linked in the description, but the problem is that it matches PA — the ISO 3166-1 code for Panama. For this reason, I think, that pa.wikimedia.org should be reserved for a future Panama affiliate, and a different convention used for language based affiliates, such as pa-lang.wikimedia.org or something along those lines.

So this is just a little funky. Usually for Wikimedia affiliate wikis (as opposed to Wikimedia projects) the subdomain code is the country code. Yet "Punjabi" doesn't have a country code, of course.

My first inclination normally would be to suggest pan.wikimedia.org (based on ISO 639–2/3, rather than ISO 639–1). But even that might be moderately complicated. What has happened with language codes here is that "pan" was first introduced as an ISO 639–2 code, then in ISO 639–3 assigned to Eastern Punjabi, while Western Punjabi got "pnb". So my question to the group members themselves is: is pan.wikimedia.org acceptable overall, or do you prefer something different?

Anybody to answer my questions above? Otherwise, I'll close this request as "Invalid" as I wasn't given enough info.

  • "Visibility": Public, private, fishbowl
  • Sitename
  • Logo
  • Do you want any specific extensions (like Translate)?
  • How should the wiki domain look like: The format is <something>.wikimedia.org for those wikis, maybe <langcode>.wikimedia.org, but I don't know the code for Punjabi.

@StevenJ81 suggested pan.wikimedia.org

Urbanecm triaged this task as Low priority.Oct 14 2018, 6:34 PM
Dzahn changed the task status from Stalled to Open.Oct 19 2018, 6:00 PM
Dzahn added a subscriber: Dzahn.

While we're on Datacenter-Switchover-2018 we ain't allowed to create new wikis.

This is over. Unstalling.

Dzahn added a comment.Oct 19 2018, 6:01 PM

Still needs user input there. Moving to new column "Stalled / Needs Input" on the Wiki-Setup workboard i created for this.

Dzahn moved this task from Create to Stalled / Needs Input on the Wiki-Setup board.
Dzahn edited projects, added Wiki-Setup; removed Wiki-Setup (Create).
Urbanecm changed the task status from Open to Stalled.Oct 19 2018, 9:33 PM

Re-stalling, gathering info can take long. Thank you for creating the column @Dzahn! As I participate on every recent wiki creation request, I was pretty familiar with tasks status and as there is not usually that number of wiki creation task, I didn't notice this column would be useful. I will write a notice mail to the requestor, to inform him this will be declined if required info isn't provided.

(note: I also emailed others on the contact persons list https://meta.wikimedia.org/wiki/Punjabi_Wikimedians)

"Visibility": fishbowl
Sitename: Punjabi Wikimedians
Logo: https://commons.wikimedia.org/wiki/File:Punjabi_Wikimedians_User_Group_logo_-_variation_1.svg
Yes Translate Extension would be helpful
Considering all the factors, we should choose pbi.wikimedia.org

Apologies for the delay.

satdeep_gill raised the priority of this task from Low to Normal.Oct 20 2018, 8:56 AM
satdeep_gill changed the task status from Stalled to Open.
Urbanecm claimed this task.Oct 20 2018, 9:52 AM
Urbanecm lowered the priority of this task from Normal to Low.
Urbanecm moved this task from Blocked on others to Working on on the User-Urbanecm board.

@satdeep_gill Please do not change task's priority if you don't plan to work on it. Priority should reflect reality, not wishes.

Urbanecm edited projects, added Wiki-Setup (Create); removed Wiki-Setup.
Urbanecm added a comment.EditedOct 20 2018, 10:00 AM

"Visibility": fishbowl
Sitename: Punjabi Wikimedians
Logo: https://commons.wikimedia.org/wiki/File:Punjabi_Wikimedians_User_Group_logo_-_variation_1.svg
Yes Translate Extension would be helpful
Considering all the factors, we should choose pbi.wikimedia.org

Per https://en.wikipedia.org/wiki/Parkwa_language, pbi is ISO639-3 code for Parkwa language. Wikis for UGs/chapters are usually focused on area, not a language (which is difference when compared with language projects). Are you sure you want pbi.wikimedia.org?

Apologies for the delay.

Base added a comment.Oct 20 2018, 2:37 PM

perhaps verbatim punjabi.wikimedia.org?

perhaps verbatim punjabi.wikimedia.org?

That's good idea, perhaps with minimal confusion overall.

Summarization of the domain issue

Condition: We do not want any conflicts, or "unreal" conflicts

List of proposed domains (append .wikimedia.org to get FQDN):

  • pa.wikimedia.org (lang code for Punjabi, can be used for Panama as well)
  • pbi.wikimedia.org (self-created code, which should be avoided because it is not standard and systematic)
  • pan.wikimedia.org (can be interpreted as Eastern Punjab)
  • punjabi.wikimedia.org (no conflicts)

I think that probability that Wikimedia Punjabi will split into eastern and western is small enough to use pan.wikimedia.org. I personally have no problem with this code.

Urbanecm added a comment.EditedOct 21 2018, 11:27 AM

@satdeep_gill approved use of verbatim punjabi.wikimedia.org by email. I should have everything necessary to create a wiki.

Urbanecm updated the task description. (Show Details)Oct 21 2018, 11:28 AM
Urbanecm updated the task description. (Show Details)Oct 21 2018, 11:34 AM
Urbanecm renamed this task from Separate Wiki for Punjabi Wikimedians User Group to Create punjabi.wikimedia.org for Punjabi Wikimedians User Group.Oct 21 2018, 11:52 AM

Change 468815 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Initial configuration for punjabiwikimedia

https://gerrit.wikimedia.org/r/468815

Urbanecm removed Urbanecm as the assignee of this task.

Change 468815 merged by jenkins-bot:
[operations/mediawiki-config@master] Initial configuration for punjabiwikimedia

https://gerrit.wikimedia.org/r/468815

Change 473488 had a related patch set uploaded (by Reedy; owner: Reedy):
[operations/mediawiki-config@master] Add new wikis to wikiversions.json

https://gerrit.wikimedia.org/r/473488

Change 473488 merged by Reedy:
[operations/mediawiki-config@master] Add new wikis to wikiversions.json

https://gerrit.wikimedia.org/r/473488

Change 473498 had a related patch set uploaded (by Reedy; owner: Reedy):
[operations/mediawiki-config@master] Remove punjabi from MWMultiversion

https://gerrit.wikimedia.org/r/473498

Change 473498 abandoned by Reedy:
Remove punjabi from MWMultiversion

https://gerrit.wikimedia.org/r/473498

Change 473507 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/services/restbase/deploy@master] Add 4 new wikis

https://gerrit.wikimedia.org/r/473507

Change 473520 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/services/parsoid@master] Add 4 new wikis

https://gerrit.wikimedia.org/r/473520

Change 473507 merged by Mobrovac:
[mediawiki/services/restbase/deploy@master] Add 4 new wikis

https://gerrit.wikimedia.org/r/473507

Change 473520 merged by jenkins-bot:
[mediawiki/services/parsoid@master] Add 4 new wikis

https://gerrit.wikimedia.org/r/473520

Meno25 added a subscriber: Meno25.Wed, Nov 14, 5:07 PM
Urbanecm added a subscriber: Reedy.Thu, Nov 15, 7:13 AM

@Reedy: Can you create initial bureaucrat user for User:Satdeep_Gill@SUL and send them a password? Thank you!

Urbanecm assigned this task to Reedy.Thu, Nov 15, 7:18 AM

Assigning those task to @Reedy as he created the wikis. Leaving open for possible fixes if those will be necessary.

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2018-11-15T12:52:10Z] <mobrovac@deploy1001> Started deploy [restbase/deploy@22cb0ec]: Add new wikis to RESTBase - T206777 T205710 T205546 T204477

Mentioned in SAL (#wikimedia-operations) [2018-11-15T13:12:06Z] <mobrovac@deploy1001> Finished deploy [restbase/deploy@22cb0ec]: Add new wikis to RESTBase - T206777 T205710 T205546 T204477 (duration: 19m 56s)

Reedy added a comment.EditedTue, Dec 4, 9:11 AM

@Reedy: Can you create initial bureaucrat user for User:Satdeep_Gill@SUL and send them a password? Thank you!

If @satdeep_gill does a password reset on punjabiwikimedia using your username or the email you have set on enwiki et al, you should be able to login as a sysop when you create a new password

Urbanecm closed this task as Resolved.Fri, Dec 7, 9:32 PM

Should be done.