Page MenuHomePhabricator

Close internal.wikimedia.org
Closed, ResolvedPublic

Description

This wiki hasn't been used for years. 10 last edits go as far as 2.5 years back. Looking at logs, the most popular human activity appears to be random Wikimedians trying to login, failing and going away. I propose to close this wiki as it serves no purpose.

Pinging @Jalexander and @Varnent for comments.

Event Timeline

MaxSem created this task.Sep 26 2018, 9:47 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 26 2018, 9:47 PM
Dzahn awarded a token.Oct 19 2018, 5:37 PM
Dzahn added a subscriber: Dzahn.
Urbanecm triaged this task as Lowest priority.
Urbanecm added a subscriber: Urbanecm.

No oppose, going to upload a patch.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptOct 21 2018, 12:24 PM

Change 468823 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Close internalwiki

https://gerrit.wikimedia.org/r/468823

FTR I'm ok with this I think I mentioned it @Varnent earlier and he didn't have an issue but I will ask again tonight :)

Ok, scheduling for tomorrow EU SWAT (as there's high probability he'll be okay with it). Let me know in case I should cancel the scheduling.

Eh, it's night in SF, please don't rush it.

Ok, reverted, will wait for explicit approval.

No objections from Wikimedia Foundation Communications department to closure of Internal Wiki. :)

Az1568 added a subscriber: Az1568.Oct 25 2018, 12:25 AM
Dzahn raised the priority of this task from Lowest to Normal.Oct 26 2018, 7:13 PM

raising priority as i learned from Andre it should reflect reality not wishes, but it is happening now.. right

I guess nihil obstat to proceed with the closure now?

Change 468823 merged by jenkins-bot:
[operations/mediawiki-config@master] Close internalwiki

https://gerrit.wikimedia.org/r/468823

Mentioned in SAL (#wikimedia-operations) [2018-12-03T12:34:23Z] <lucaswerkmeister-wmde@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:468823|Close internalwiki (T205584)]] (duration: 00m 46s)

Urbanecm closed this task as Resolved.Dec 3 2018, 12:36 PM

I guess nihil obstat to proceed with the closure now?

Agreed.

jhsoby added a subscriber: jhsoby.Jan 2 2019, 12:24 PM

What does "close" mean in this context? I was able to make an edit there just now.

@jhsoby - Closure means that the wiki cannot be editted by regular users. In public wikis it means only Wikimedia stewards, sysadmins and staff. In private wikis this may differ as the permissions configurations do vary. You should check Special:ListGroupRights and see who has 'edit' permissions there.

jhsoby added a comment.EditedJan 2 2019, 2:39 PM

The edit right is assigned to the group "Users", which means that nothing has really changed (since only that group could read and edit before this change). All the patch did in reality, then, was to put a strike through internal in Special:SiteMatrix …

We should then create a follow-up patch revoking the edit right to anyone. But given that this is a private wiki I wonder if we should care at all.

Well...this is the configuration for wikis that are in closed.dblist.

// Read-only (except stewards)
'closed' => [
        '*' => [
                'edit' => false,
                'createaccount' => false,
        ],
        'user' => [
                'edit' => false,
                'move' => false,
                'move-rootuserpages' => false,
                'move-subpages' => false,
                'upload' => false,
        ],
        'autoconfirmed' => [
                'upload' => false,
                'move' => false,
        ],
        'sysop' => [
                'block' => false,
                'delete' => false,
                'undelete' => false,
                'import' => false,
                'move' => false,
                'move-subpages' => false,
                'move-rootuserpages' => false,
                'patrol' => false,
                'protect' => false,
                'editprotected' => false,
                'rollback' => false,
                'trackback' => false,
                'upload' => false,
                'movefile' => false,
        ],
        'steward' => [
                'edit' => true,
                'move' => true,
                'delete' => true,
                'upload' => true,
        ],
],

I suspect the problem is that only one of the entries in groupOverrides matches. For internalwiki, private and closed can match, as internalwiki is in both private.dblist and closed.dblist, but apparently, only private matches, setting it as a private wiki, and the configuration for closed wikis is just ignored. Moving configuration for private to groupOverrides2 will probably solve this problem, however, I'm not sure if doing so won't break the default configuration there.

For all subscribers, even the closure didn't take effect on first place, it is still in the configuration. As such, it'll automatically take effect when T227980 is resolved.