Page MenuHomePhabricator

deploy1001:/srv/mediawiki out of date?
Closed, ResolvedPublic

Description

Not sure what happened, but /srv/mediawiki-staging seems to have been rather out of date

reedy@deploy1001:/srv/mediawiki-staging$ scap wikiversions-inuse
1.32.0-wmf.24 1.32.0-wmf.26
reedy@deploy1001:/srv/mediawiki$ grep 24 wikiversions* -c
wikiversions.json:927
wikiversions-labs.json:0
wikiversions.php:927
reedy@deploy1001:/srv/mediawiki$ scap pull
15:59:56 Copying to deploy1001.eqiad.wmnet from deploy1001.eqiad.wmnet
15:59:56 Started rsync common
16:01:58 Finished rsync common (duration: 02m 01s)
16:01:58 Started scap-cdb-rebuild
16:02:54 Finished scap-cdb-rebuild (duration: 00m 55s)
reedy@deploy1001:/srv/mediawiki$ scap wikiversions-inuse
1.32.0-wmf.26
reedy@deploy1001:/srv/mediawiki$

Event Timeline

Reedy created this task.Oct 21 2018, 4:04 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 21 2018, 4:04 PM
thcipriani moved this task from Needs triage to Debt on the Scap board.Oct 23 2018, 4:11 PM
thcipriani triaged this task as Normal priority.
thcipriani moved this task from Backlog to In-progress on the Release-Engineering-Team (Kanban) board.
thcipriani claimed this task.

There are 928 wikis in wikiversions.{json,php}. If 927 showed up as being on the previous versions, this leads me to believe wikiversions is only getting updated in /srv/mediawiki on the deployment host during scap sync and not for any subsequent updates from scap sync-wikiversions.

We now run sync_common as part of every sync so that the deployment master stays up-to-date with the rest of the fleet. Picking a random scap sync-wikiversions from the train last week (https://tools.wmflabs.org/sal/log/AWaIHfVj9KCHCtNUkCNo), I see this ran on deploy1001 at 2018-10-18T16:58:01

Running rsync command: `sudo -u mwdeploy -n -- /usr/bin/rsync --archive --delete-delay --delay-updates --compress --delete --exclude=**/cache/l10n/*.cdb --exclude=*.swp --no-perms --exclude=**/.git --include=/ --include=//wikiversions*.{json,php} --include=/php-*/cache/gitinfo --exclude=* deploy1001.eqiad.wmnet::common /srv/mediawiki`

The problem is --include=//wikiversions*.{json,php}. I've created D1120: Remove '/' from include in sync-wikiversions to solve the problem. The impact here is that scap wikiversions-inuse will be out of date following scap sync-wikiversions unless followed by scap pull.

thcipriani closed this task as Resolved.

Now that scap 3.8.10-1 is out, this should be fixed!