Page MenuHomePhabricator

PNG cannot display thumbnails if the original over 12.5 megapixels
Closed, ResolvedPublic

Description

Can the limit on PNG thumbnailing please be raised? TIFFs are generally twice the filesize of PNGs, cannot display at all well in any modern browser (should one click on the link to the full size image) and, furthermore, don't thumbnail at all, so PNG is still the best choice for restoration, but the 12.5 megapixel lmiot is still in effect, even as the upload limit was raised to 100 megs.

I presume this is simply an arbitrary limit chosen back when the max upload size was much smaller. It's completely untenable now.


Version: unspecified
Severity: enhancement

Details

Reference
bz18826

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 21 2014, 10:39 PM
bzimport set Reference to bz18826.
bzimport added a subscriber: Unknown Object (MLST).

ayg wrote:

This doesn't sound like a MediaWiki issue to me at all, it's probably a config option. If so, it should have Product: Wikimedia.

The limit was most likely chosen to avoid ImageMagick taking too much memory or such. Comforting though it may be to think otherwise, sysadmins usually don't try to make arbitrary limits to annoy people.

Definitely not a MW issue, updating product as such.

brion added a comment.May 18 2009, 6:00 PM

This is due to image thumbnailing of very large non-JPEG images frequently breaking and taking down the whole site's thumbnailing service. In the future we'd like to have better thumbnailing of huge images but this is dependent on new infrastructure.

Well, then, can efforts be put into improving this, or, alternatively, to remove the huge grey squares informing people of the problem and replace it with a simple download icon? ~~~~

mike.lifeguard+bugs wrote:

(In reply to comment #4)

Well, then, can efforts be put into improving this, or, alternatively, to
remove the huge grey squares informing people of the problem and replace it
with a simple download icon? ~~~~

Yes, that's why it's marked as later. We may be seeing progress over the summer: http://socghop.appspot.com/student_project/show/google/gsoc2009/wikimedia/t124025075087

Has the GSOC '09 project helped in resolving this issue? Or more generally,has this issue been resolved?

VipsScaler should handle this: bug 28135. Setting as a blocker on this bug and reopening this.

brylie wrote:

This limit is enabled on the Wikimedia Commons, and is preventing large panoramas from having preview thumbnails. What infrastructure changes would support thumbnail generation for PNGs > 12.5 megapixels?

(In reply to comment #8)

What infrastructure changes would
support thumbnail generation for PNGs > 12.5 megapixels?

Please see the status of bug 28135

I think this is a dupl. of Bug #9497 !?

(In reply to comment #10)

I think this is a dupl. of Bug #9497 !?

If so please mark this as "resolved duplicate" because I can't do so.

TheDJ added a comment.Aug 23 2012, 4:41 PM
  • This bug has been marked as a duplicate of bug 9497 ***