Page MenuHomePhabricator

mycustomjsredirectprotected * not permitted to edit user JS after moving in own user space
Closed, ResolvedPublic

Description

Steps to reproduce:

  • Create some .js page in own user space
  • move to some other .js page in the identical own user space
  • move is executed
  • generated target page is fine
  • original redirect page is not editable any longer
  • message: int:mycustomjsredirectprotected
  • page is not protected

Generated page content as follows:

/* #REDIRECT */mw.loader.load("//en.wikipedia.org/w/index.php?title=User:@@@@@/myscript.js\u0026action=raw\u0026ctype=text/javascript");

I want to get back the right to edit this page in my own user space.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 22 2018, 7:23 PM

Failure error "You do not have permission to edit this JavaScript page because it is a redirect."

Xaosflux added a comment.EditedDec 1 2018, 7:44 PM

@Aklapper while this is similar to T210922 it should only be a duplicate if this is going to actually be worked on, else T210922 should still be solved the same way T (the one for admins to be able to delete js in general) was.
(That is if these redirects are supposed to be blocked from editing for some reason?)

Tgr added a comment.Dec 2 2018, 4:39 AM

There is a fix for this in T207750.

@Tgr can you add me to T207750 ?

Tgr closed this task as Resolved.Dec 18 2018, 8:21 PM
Tgr claimed this task.

I'm not sure what the current rules for adding people to security tasks are. Anyway, this should be fixed now.