Page MenuHomePhabricator

Increase max number of edits in watchlist
Open, Needs TriagePublic

Description

Please, increase max number of edits in watchlist from 1000 to, for example, 2000 or, at least, 1500. My watchlist contains 30k pages, I have no Internet access at work, so, when I get home and browse watchlist for last 16-18 hours, it often contains more then 1000 edits, edits from several early hours are lost. Yes, I can browse it "by slices", using namespace filter, but it's very uncomfortable.

Event Timeline

Restricted Application added a project: Growth-Team. · View Herald TranscriptJan 9 2019, 11:27 AM
Restricted Application added subscribers: Base, Aklapper. · View Herald Transcript

Even when I set filter "show only main namespace and main talk edits", 1000 edits accumulate in less then 24 hours.

Aklapper reopened this task as Open.Jan 9 2019, 12:28 PM
Aklapper closed this task as a duplicate of T210897: Recent changes limit lowered to 1000.

Argh, T210897 is about RC while this is about Watchlist, sorry. Reopening.

If you upload 150 files with the upload wizard this alone might result in 750 watchlist outputs:

150x upload log
150x caption added
150x depict added
150x categorization
150x changes by another user (adding a category or cleaning a syntax error)

If you have one or more noticeboards on watch, a single use of the upload wizard can flood a 1000 actions watchlist in seconds.

Should in the future mass edits to add depict statements occur my watchlist with 14000 uploaded files may unexpectedly be flooded over night.