Page MenuHomePhabricator

Incorrect label display in Russian localization
Closed, ResolvedPublic

Description

In Russian localization, label "Wikipedia-ios-page-read-in-other-languages" is display as `(null)`. See screenshot.
Sorry for my English.

ver. 6.1.4 (1537); iOS 12.1.3

Testing criteria

  • load any Russian language article
  • scroll to the bottom footer menu
  • ensure the languages entry in the footer menu doesn't display the 'null' string from the screenshot below. it should instead show a Russian string saying how many languages the article is available in

Event Timeline

Iluvatar created this task.Jan 28 2019, 5:50 PM
Restricted Application added a project: Wikipedia-iOS-App-Backlog. · View Herald TranscriptJan 28 2019, 5:50 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Iluvatar updated the task description. (Show Details)Jan 28 2019, 5:53 PM

@Iluvatar what's the article in the screenshot?

The problem is in any article in Russian.
Screenshot of the article Братья Львиное сердце

LGoto triaged this task as Low priority.Feb 7 2019, 8:23 PM
LGoto moved this task from Needs Triage to Bug Backlog on the Wikipedia-iOS-App-Backlog board.
Mhurd claimed this task.Feb 8 2019, 11:12 PM

Follow up adding test and fixing other issues the test surfaced:
https://github.com/wikimedia/wikipedia-ios/pull/2907

Moved to blocked until I hear back on i18n ticket I filed https://phabricator.wikimedia.org/T215854

ABorbaWMF added a subscriber: ABorbaWMF.

Looks good to me on 6.2.1 (1586)

JMinor closed this task as Resolved.Apr 9 2019, 5:27 PM