Page MenuHomePhabricator

CI permission errors causing tests to fail
Closed, ResolvedPublic

Description

Failing due to rsync/permissions issues seemingly. Not got time to debug atm

https://integration.wikimedia.org/ci/job/wmf-quibble-core-vendor-mysql-hhvm-docker/8979/console

20:23:21 [wmf-quibble-core-vendor-mysql-hhvm-docker] $ /bin/bash -xe /tmp/jenkins2246946716714126380.sh
20:23:21 + set -eux
20:23:21 + mkdir -m 2777 -p log
20:23:21 mkdir: cannot create directory ‘log’: Permission denied
20:23:21 Build step 'Execute shell' marked build as failure

Event Timeline

Reedy created this task.Feb 13 2019, 3:25 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 13 2019, 3:25 AM
Reedy triaged this task as High priority.Feb 13 2019, 3:26 AM
Reedy updated the task description. (Show Details)
Legoktm renamed this task from Many tests are currently failing :( to CI permission errors causing tests to fial.Feb 13 2019, 4:29 AM
Legoktm raised the priority of this task from High to Unbreak Now!.
Legoktm updated the task description. (Show Details)
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptFeb 13 2019, 4:29 AM
Legoktm renamed this task from CI permission errors causing tests to fial to CI permission errors causing tests to fail.Feb 13 2019, 4:32 AM

Is this still happening? I think this was resolved on Wednesday? I don't currently see an inordinate number of jobs failing.

hashar closed this task as Resolved.Feb 19 2019, 9:25 AM
hashar added a subscriber: hashar.

When it happens, it is due to a faulty job which has the log directory created within docker and thus is owned by root. That causes the next build to fail to create the directory. Meanwhile the slave integration-slave-docker-1047 has been deleted for some reason. So that is fixed for now, root cause left to be figured out but we can look at that next time it occurs again.