Page MenuHomePhabricator

AdvancedSearch should always create URLs unambiguous about the namespaces being used
Closed, ResolvedPublic1 Story Points

Description

Motivation
When a search is done with "profile=advanced", and no namespaces are mentioned explicitely, the same link may render different search results for users: Every user gets what they decided to remember as "their" namespace bundle, or the wiki default if they don't have one.
We would like to make sure, that coming from AdvancedSearch users can send each other URLs that return the same results to everyone.

Acceptance Criteria

  • URLs created by AdvancedSearch are always unambiguous about the namespaces that are being used
  • Even if users did not enter any namespace when hitting the Search button, they URL of the search results reflects the namespaces used for creating the results

Event Timeline

Restricted Application added a project: TCB-Team. · View Herald TranscriptMar 1 2019, 8:53 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Tim_WMDE added a subscriber: Tim_WMDE.EditedMar 6 2019, 10:10 AM

Since Lea explained this ticket to me in person, here's a quick rephrased explanation of this ticket:

Steps to reproduce:

  1. Make sure you are logged in and go to: https://de.wikipedia.org/w/index.php?search=&title=Spezial%3ASuche&go=Artikel
  2. Select all namespaces by clicking on "Alle" and perform a search with a search term of your choice.
    1. You should now be able to see all namespaces listed in the URL while on the search result page
  3. Deselect all namespaces by clicking on "Alle" again and perform another search.
  4. Since no namespaces were selected, the search defaults back to the namespaces you have stored in your account.

After the last step, it will show you the search results with the namespaces you have "remembered" in your account but the URL does not reflect that. Instead, the URL will look like this, completely missing the namespace parameters that were actually used by your user defaults:

https://de.wikipedia.org/w/index.php?search=Test&title=Spezial%3ASuche&profile=advanced&fulltext=1&advancedSearch-current=%7B%7D

The issue is that if people share this URL now, the search results will look different depending on what individual users have selected to be their default namespaces. The task of this ticket is to ensure that currently selected namespaces are always reflected in the URL, even if the search uses the default namespaces of the current user.

Tim_WMDE set the point value for this task to 5.Mar 11 2019, 1:11 PM
Tim_WMDE claimed this task.Mar 11 2019, 2:30 PM
Tim_WMDE moved this task from Todo to Doing on the WMDE-FUN-Sprint-2019-03-04 board.

Change 496163 had a related patch set uploaded (by Tim Eulitz; owner: Tim Eulitz):
[mediawiki/extensions/AdvancedSearch@master] Ensure namespaces are always part of search URLs

https://gerrit.wikimedia.org/r/496163

Tim_WMDE removed Tim_WMDE as the assignee of this task.Mar 13 2019, 3:52 PM
Tim_WMDE moved this task from Doing to Review on the WMDE-FUN-Sprint-2019-03-04 board.
kai.nissen changed the point value for this task from 5 to 1.Mar 18 2019, 11:13 AM

Change 496163 had a related patch set uploaded (by WMDE-Fisch; owner: Tim Eulitz):
[mediawiki/extensions/AdvancedSearch@master] Ensure namespaces are always part of search URLs

https://gerrit.wikimedia.org/r/496163

Change 496163 merged by jenkins-bot:
[mediawiki/extensions/AdvancedSearch@master] Ensure namespaces are always part of search URLs

https://gerrit.wikimedia.org/r/496163

kai.nissen closed this task as Resolved.Apr 15 2019, 11:04 AM