Page MenuHomePhabricator

Regression: "Expand all sections" setting in Minerva is broken
Closed, ResolvedPublic

Description

Broken in Id16a64573e020b4606fc9b11456163a4cd290e0b (via git blame) in wmf/1.33.0-wmf.16

Steps to reproduce

  1. on mobile enable the "Expand all sections" setting
  2. go to https://en.m.wikipedia.org/wiki/Maurice_Ravel
  3. scroll down past the first section

Expected results

  • All sections are expanded
  • Section dropdown arrows are present
  • Edit buttons are NOT present

Actual results

  • Sections are not expanded
  • Section dropdown arrows do not appear
  • Edit buttons appear

Environments observed

  • Browser version: Chrome 72.0.3626 / OS version: Android 9 / Device model: Honor 10
  • Browser version: Safari / OS version: iOS / Device model: iPhone 6

NOT observed on the beta cluster where it seems the sections are currently uncollapsed by default with the toggle off (same device/browser)

QA steps

Smoke test

Test on a mobile device (iOS Safari+Chrome Android suggested)

Check "memory" (i.e. that collapsed/expended sections persist after a page refresh).

Make sure using mobile device and expanded sections setting is OFF in settings.

QA Results

StatusDetails
✅ PassedT217820#5021636

Details

Related Gerrit Patches:
mediawiki/skins/MinervaNeue : wmf/1.33.0-wmf.20Passing page parameter to TOC toggler
mediawiki/skins/MinervaNeue : masterPassing page parameter to TOC toggler

Event Timeline

ovasileva created this task.Mar 7 2019, 9:10 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 7 2019, 9:10 AM
ovasileva triaged this task as High priority.Mar 7 2019, 9:11 AM
ovasileva moved this task from Incoming to Needs Prioritization on the Readers-Web-Backlog board.
ovasileva updated the task description. (Show Details)
ovasileva updated the task description. (Show Details)Mar 7 2019, 9:14 AM

Change 494889 had a related patch set uploaded (by Jdrewniak; owner: Jdrewniak):
[mediawiki/skins/MinervaNeue@master] Passing page parameter to TOC toggler

https://gerrit.wikimedia.org/r/494889

Change 494889 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Passing page parameter to TOC toggler

https://gerrit.wikimedia.org/r/494889

Jdlrobson renamed this task from [Bug] Section dropdowns not appearing on Chrome in Minerva to [Bug] Section dropdowns not appearing on Chrome in Minerva when "expand all sections" setting is enabled.Mar 7 2019, 6:12 PM
alexhollender updated the task description. (Show Details)Mar 7 2019, 6:22 PM
alexhollender renamed this task from [Bug] Section dropdowns not appearing on Chrome in Minerva when "expand all sections" setting is enabled to [Bug] "Expand all sections" setting in Minerva is broken.Mar 7 2019, 6:25 PM
alexhollender updated the task description. (Show Details)
alexhollender updated the task description. (Show Details)
ovasileva updated the task description. (Show Details)Mar 7 2019, 6:27 PM
Force_Radical rescinded a token.
Jdlrobson updated the task description. (Show Details)Mar 7 2019, 6:42 PM

Change 495021 had a related patch set uploaded (by Jdlrobson; owner: Jdrewniak):
[mediawiki/skins/MinervaNeue@wmf/1.33.0-wmf.20] Passing page parameter to TOC toggler

https://gerrit.wikimedia.org/r/495021

Jdlrobson updated the task description. (Show Details)Mar 7 2019, 7:37 PM
Jdlrobson added subscribers: Edtadros, Jdlrobson.

Added to SWAT today 4pm PST as this is causing JavaScript client errors cc @Edtadros we'll want to QA this before then.
https://grafana.wikimedia.org/d/000000566/overview?panelId=15&fullscreen&orgId=1

Jdlrobson renamed this task from [Bug] "Expand all sections" setting in Minerva is broken to Regression: "Expand all sections" setting in Minerva is broken.Mar 7 2019, 7:47 PM
Jdlrobson added a project: Regression.
Jdlrobson updated the task description. (Show Details)
Jdrewniak updated the task description. (Show Details)Mar 7 2019, 9:32 PM

Change 495021 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@wmf/1.33.0-wmf.20] Passing page parameter to TOC toggler

https://gerrit.wikimedia.org/r/495021

Mentioned in SAL (#wikimedia-operations) [2019-03-08T00:23:43Z] <thcipriani@deploy1001> Synchronized php-1.33.0-wmf.20/skins/MinervaNeue/resources/skins.minerva.scripts/toc.js: SWAT: [[gerrit:495021|Passing page parameter to TOC toggler]] T217820 (duration: 00m 50s)

@Jdlrobson I wasn't sure if you wanted me to test this yet. I went through and got myself familiar with what I could. I couldn't find the "Expand all sections" setting and the beta cluster page throws an error, which I assume will be fixed when it's ready for me to test.

Jdlrobson updated the task description. (Show Details)Mar 12 2019, 9:08 PM

Sorry about the miscommunication here. The hope was to test this before the SWAT deploy on Thursday. The fix is also live on production. I've updated the QA instructions, please go ahead and test!

Edtadros reassigned this task from Edtadros to Jdlrobson.EditedMar 13 2019, 5:03 PM

Test Result

Status: ✅ PASS
OS: macOS Mojave
Browser: Chrome DevTools Device Emulator (Galaxy S5)

Test Artifact(s):

QA steps

Click expanded sections
Visit https://en.m.wikipedia.org/wiki/May_14
Make sure that the arrows for collapsing are visible

Visit the same page on beta cluster https://en.m.wikipedia.beta.wmflabs.org/wiki/May_14
Check the arrows for collapsing are visible there too

Check "memory" (i.e. that collapsed/expended sections persist after a page refresh).
Make sure using mobile device and expanded sections setting is OFF in settings.

Visit https://en.m.wikipedia.org/wiki/May_14
Open 2 sections making a note of their headings
Births and Deaths expanded (Note: Deaths doesn't show up in the image)

Refresh the page
Verify that the sections you opened in the previous view are still open.
Births and Deaths expanded (Note: Deaths doesn't show up in the image)

Edtadros updated the task description. (Show Details)Mar 13 2019, 5:03 PM
Jdlrobson reassigned this task from Jdlrobson to Edtadros.Mar 13 2019, 6:44 PM

Talked about this today. There was QA confusion caused by T159475.

Edtadros reassigned this task from Edtadros to ovasileva.Mar 14 2019, 12:58 AM

Updated the test results T217820#5021636 to confirm that this passes.

ovasileva closed this task as Resolved.Mar 14 2019, 10:32 AM