Page MenuHomePhabricator

Multiple issues with scrolling in the "Add discussion" overlay on iOS render it unusable (can't save, can't type long messages)
Closed, ResolvedPublic

Description

There are multiple weird issues with scrolling in the "Add discussion" overlay.

  1. After tapping in the "What is on your mind?" field, the dialog header scrolls out of view and can't be scrolled back in. There is no way to tap "Save".



    There are two weird tricks that can bring the header back into view:
    1. Try scrolling down, then up, without letting go
    2. Tap the time on the top bar (which is a secret global shortcut to scroll to top)
  1. After typing in some long text, enough that scrolling would be necessary to view it all, you discover that the text input can't actually be scrolled up.



    I couldn't find any way to make it scroll. Seemingly it can be navigated by moving the selection (text cursor), but that is very error-prone.

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterRestrict iOS scrolling emulation to overlays that need it

Event Timeline

matmarex created this task.Mar 12 2019, 4:28 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 12 2019, 4:28 AM

Change 495826 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] Overlay: Refactor code to prevent browser viewport scrolling on iOS

https://gerrit.wikimedia.org/r/495826

ovasileva triaged this task as High priority.Mar 12 2019, 9:59 AM
ovasileva moved this task from Incoming to Needs Prioritization on the Readers-Web-Backlog board.

I tried to test this today, but am having trouble replicating. If this needs a real physical device to test the issue can you state so in the ticket description? I can't seem to replicate this bug in browserstack.

I don't know if it can be reproduced using Browserstack, I never used it. I encountered the issue on an actual iPhone SE running iOS 12.1.4, using the Safari browser.

Change 496571 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Restrict iOS scrolling emulation to overlays that need it

https://gerrit.wikimedia.org/r/496571

Change 496571 merged by Jdlrobson:
[mediawiki/extensions/MobileFrontend@master] Restrict iOS scrolling emulation to overlays that need it

https://gerrit.wikimedia.org/r/496571

Mentioned in SAL (#wikimedia-operations) [2019-03-15T17:59:54Z] <thcipriani@deploy1001> Synchronized php-1.33.0-wmf.21/extensions/MobileFrontend: SWAT: [[gerrit:496827|iOS: Fix mobile editor]] T218069 T218062 T218352 T211490 T218062 T211491 T172877 (duration: 00m 54s)

matmarex closed this task as Resolved.Mar 25 2019, 6:58 PM

Seems to work correctly after that patch. I'm assuming you're not planning to do any QA or any other work on this, since it's in the "Backlog" project, so let's just close it.