Page MenuHomePhabricator

[Alpha/Labs] Search bar: keyword and depicts tags appear on top of Qualifier input window
Closed, ResolvedPublicBug

Description

User story: N/A

We have this hot mess:

We want this:
Qualifier element should be on top of the tabs (z-indexes, baby!)

Screenshots (if possible):

Acceptance Criteria:

  • The qualifier window appears on top of all other page elements

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 19 2019, 1:47 AM
Ramsey-WMF triaged this task as Normal priority.Mar 19 2019, 1:47 AM

Odd, not the case on my environment. But let's lock those z-indices down, since default obviously can't be trusted :)

I'm going to do things a little differently.

Hiding the keyword|tags toggle behind the qualifier input window is equally problematic when the user start typing another tag when the qualifier window is still open:

  • when they do, the autocomplete needs to show up
  • and if that toggle is hidden (which the autocomplete is attached to), the autocomplete would just appear to be randomly floating there
  • (or we'd also have to hide autocomplete behind the qualifier window)

Instead, I suggest we should just bring the thing that is focused to the front:

  • when the input field is focused, even if qualifier popup is open, it will come to the front (along with the toggle and the autocomplete)
  • when clicking a capsule to open the qualifier window, input loses focus, toggle & autocomplete disappear
  • when input receives focus again, toggle comes back to the front, and autocomplete will (re)appear if/once there's input

Ok?

Change 441040 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/WikibaseMediaInfo@master] Search prototype

https://gerrit.wikimedia.org/r/441040

Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.Mar 19 2019, 6:02 PM

Change 441040 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Search prototype

https://gerrit.wikimedia.org/r/441040

matthiasmullie added a subscriber: matthiasmullie.

Reassigning to confirm solution outlined in https://phabricator.wikimedia.org/T218630#5036226 is good

I'd like to confirm it, but autosuggest dropdowns aren't appearing on Labs right now :)

Reassigning to confirm solution outlined in https://phabricator.wikimedia.org/T218630#5036226 is good

That might've been because of T219540. Pulled all new code on labs, should be fixed now (WFM at least) - can you try again?
(or try on beta - code was already merged)

It's working now. Still a bit weird though. I think the problem is the first run scenario where, for the first few times you add a tag, we automatically show the qualifier popover as soon as you add it. The popover ends up behind the keyword and tags buttons and is jarring.

For those first "hey, look at this!" in your face popups, can we just get those to show up on top/grab focus as soon as they appear?

I also feel like it would be better if qualifier windows simply disappeared if the input box has focus. Possible?

Ramsey-WMF closed this task as Resolved.Apr 10 2019, 5:13 PM

Closing this, as the current fix resolved this specific problem and user testing showed we definitely don't want to do the automatic display of the qualifier window on the first few runs. We may go with a different system for search qualifiers in general. TBD.