Page MenuHomePhabricator

During UploadWizard process, issue with Captions blocked the process
Closed, ResolvedPublic

Description

I was using UploadWizard to transfer some files to Flickr. During the description step, I filled in Captions (and other elements), and reached the upload step.

The following happened:

“Something went wrong with uploading captions”, leaving the UploadWizard in that state − it was not possible to move forward to the next step (the ThankYou and the list of files uploaded), nor to move back to the previous step.

Event Timeline

JeanFred created this task.Mar 29 2019, 9:29 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptMar 29 2019, 9:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.Apr 2 2019, 3:55 PM

Change 501189 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/UploadWizard@master] Don't submit baserevid for captions

https://gerrit.wikimedia.org/r/501189

So this edit conflict was caused by FlickreviewR 2 bot being fast enough to score an edit while captions are still being submitted.
Fix coming up.

Change 501189 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Don't submit baserevid for captions

https://gerrit.wikimedia.org/r/501189

@JeanFred this should be fixed now, can you verify?

Not sure how I would reproduce that to be honest :)
(Maybe uploading two dozen files from Flickr increases the chance that the bot scores an edit in the meantime ?)

Yeah, it's pretty hard to test as it depends on the timing of a couple of things...
As we're unable to reproduce this now, I suggest we resolve this ticket. If the problem reappears, we can reopen or file a new ticket.
Sounds good?

Actually, the more captions are added, the longer submitting all of them (sequentially) will take, and the better the odds of the bot making its edit.
We should try an upload with 10 or so captions, and we can validate whether the bot edited in time by examining the file's history.
Let's see... :)

matthiasmullie closed this task as Resolved.Apr 17 2019, 3:24 PM

Okay, this seems to have worked: FlickreviewR 2 got its edit in, and captions kept submitting.