Page MenuHomePhabricator

'Confirm you want to leave' unload message shown when it shouldn't be
Closed, ResolvedPublicBug

Description

User story: N/A

Steps to reproduce:

  • go to a page containing depicts tags e.g. https://commons.wikimedia.beta.wmflabs.org/wiki/File:Kinder_spelen-Catchpenny_print_KB-Borms_0554.jpeg
  • click 'mark as prominent' on one of the depicts statements
  • click 'cancel' to return to read mode
  • you'll get a dialog asking 'are you sure? changes will not be saved' - click 'ok'
  • try to reload the page - you'll get a msg saying 'this page is asking you to confirm that you want to leave ...', but you shouldn't be getting the msg because you cancelled your change and none of the data has changed

Acceptance Criteria:

  • leave page confirmation popup not shown when data has not changed

QA Results

ACStatusDetails
1T219771#5096261

Event Timeline

Cparle created this task.Apr 1 2019, 10:24 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 1 2019, 10:24 AM
Cparle updated the task description. (Show Details)Apr 1 2019, 10:24 AM
Ramsey-WMF triaged this task as High priority.Apr 1 2019, 3:45 PM
Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.
Ramsey-WMF assigned this task to Ha78na.
Ha78na moved this task from To Do to Doing on the Multimedia-Current-Work board.Apr 2 2019, 4:05 PM

Change 501047 had a related patch set uploaded (by Ha78na; owner: Ha78na):
[mediawiki/extensions/WikibaseMediaInfo@master] Fix 'Discard Changes' and 'Leave Site' alerts

https://gerrit.wikimedia.org/r/501047

Change 501047 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Fix 'Discard Changes' and 'Leave Site' alerts

https://gerrit.wikimedia.org/r/501047

Ha78na reassigned this task from Ha78na to Edtadros.Apr 5 2019, 4:42 PM
Ha78na added a subscriber: Ha78na.
Edtadros reassigned this task from Edtadros to Ramsey-WMF.Apr 9 2019, 5:40 AM
Edtadros added a subscriber: Edtadros.

**=== Test Result

Status: ✅ PASS
OS: macOS Mojave
Browser: Chrome
Device: MBP

Test Artifact(s):

QA Steps

go to a page containing depicts tags e.g. https://commons.wikimedia.beta.wmflabs.org/wiki/File:Kinder_spelen-Catchpenny_print_KB-Borms_0554.jpeg
click 'mark as prominent' on one of the depicts statements

click 'cancel' to return to read mode
you'll get a dialog asking 'are you sure? changes will not be saved' - click 'ok'

try to reload the page - you'll get a msg saying 'this page is asking you to confirm that you want to leave ...', but you shouldn't be getting the msg because you cancelled your change and none of the data has changed
Acceptance Criteria:

✅ leave page confirmation popup not shown when data has not changed
No dialog or popup appeared when the page was reloaded. I also verified that if I didn't click on Ok in the earlier step to dismiss the 'are you sure?' dialog, a popup would appear.

Edtadros updated the task description. (Show Details)Apr 9 2019, 5:40 AM
Ramsey-WMF added a subscriber: PDrouin-WMF.

Confirmed that this works on Beta, but the code has not hit test Commons yet. Want to take a look, @PDrouin-WMF ?

Same results as @Ramsey-WMF - works on Beta but not yet on Commons.

Ramsey-WMF claimed this task.
Ramsey-WMF moved this task from To Do to Deployment/Config on the SDC Engineering board.

ok on test-commons

Ramsey-WMF closed this task as Resolved.Apr 24 2019, 12:33 AM

works as expected on production