Page MenuHomePhabricator

Unable to interact with ButtonSelectWidget, RadioSelectWidget etc. using keyboard
Closed, ResolvedPublicBUG REPORT

Description

While working on T174819: Show last 250 changes and period selection dropdowns are not keyboard accessible I noticed that it's not possible to tab through ButtonSelectWidgets. You can see this on the demo page; tab will only focus the already highlighted ButtonSelectWidget.

This is sort of a regression as one used to be able to use arrow keys to navigate between the widgets, see for example OOUI 0.24.4.

Ideally one could use tab to navigate between the ButtonSelectWidgets and press enter to "click" on them.

Details

Related Gerrit Patches:

Event Timeline

kostajh created this task.Apr 5 2019, 8:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 5 2019, 8:45 PM
kostajh changed the subtype of this task from "Task" to "Bug Report".Apr 5 2019, 8:45 PM
Volker_E raised the priority of this task from Medium to High.Apr 6 2019, 2:00 AM
Volker_E moved this task from Backlog to Next-up on the OOUI board.

At a glance, this might be caused by rGOJUcfaea5347d69: SelectWidget: Allow multiselect mode, add to MenuTagMultiselectWidget.

SelectWidget.js
-		currentItem = this.findHighlightedItem() || this.findSelectedItem();
+		currentItem = this.findHighlightedItem();

ButtonSelectWidget items are not highlightable, only selectable, so now this code can't find the selected item and navigate to the next/prev using arrow keys.

matmarex renamed this task from Unable to interact with ButtonSelectWidget using keyboard to Unable to interact with ButtonSelectWidget, RadioSelectWidget etc. using keyboard.Apr 30 2019, 12:43 AM
matmarex added a subscriber: Esanders.

Change 511003 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[oojs/ui@master] SelectWidget: Fix accessibility issue with select widgets

https://gerrit.wikimedia.org/r/511003

Mooeypoo claimed this task.May 18 2019, 9:29 AM
Mooeypoo moved this task from Next-up to Reviewing on the OOUI board.

Change 511003 merged by jenkins-bot:
[oojs/ui@master] SelectWidget: Fix accessibility issue with select widgets

https://gerrit.wikimedia.org/r/511003

Volker_E closed this task as Resolved.May 18 2019, 2:46 PM
Volker_E moved this task from Reviewing to OOUI-0.32.0 on the OOUI board.
Volker_E edited projects, added OOUI (OOUI-0.32.0); removed OOUI.
Volker_E removed a project: Patch-For-Review.

Change 513020 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/core@master] Update OOUI to v0.32.0

https://gerrit.wikimedia.org/r/513020

Change 513020 merged by jenkins-bot:
[mediawiki/core@master] Update OOUI to v0.32.0

https://gerrit.wikimedia.org/r/513020