Page MenuHomePhabricator

"Next article" button in toolbar is broken when feed is sorted by oldest articles
Closed, InvalidPublicBug

Description

Steps to Reproduce:

  1. Open https://en.wikipedia.org/wiki/Special:NewPagesFeed
  2. Select "New Page Patrol" and sort by "oldest"
  3. Choose oldest article and click review
  4. From the article click the arrows to go to the new article in the queue

Actual Results:
For old articles this button then greys out. It doesn't seem to effect articles from 2018 and does effect articles from 2008. I don't know where in that range the cut-off is.

Expected Results:
Takes you to the next article in the queue.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 25 2019, 12:30 AM
Restricted Application added a project: Growth-Team. · View Herald TranscriptApr 25 2019, 12:45 AM
gh87 renamed this task from EN-Wikipedia NPP Toolbar rboekn to EN-Wikipedia NPP Toolbar broken.Apr 25 2019, 1:23 AM

I can now tell you that it is not affecting 2017 and IS affecting 2015. I don't know about 2016 yet.

MMiller_WMF added subscribers: Niharika, MMiller_WMF.

@Barkeep49 -- I talked about this with @Niharika because the Community Tech team is starting to work on the NPP wishlist items. Would you say that this issue is more or less important than the majority of the issues already on that list? How much is it blocking you and other reviewers?

It's an annoyance for me rather than a dealbreaker. At the same time it's something broken, and broken recently, as opposed to things that would make life better but we never had.

MusikAnimal renamed this task from EN-Wikipedia NPP Toolbar broken to "Next article" button in toolbar is broken when feed is sorted by oldest articles.May 1 2019, 2:34 AM

I was not able to reproduce this. Sorting by "oldest", the "next" button is not grayed out, and correctly goes to the next article as it appears in the queue. In my case the oldest article was from 2005 (though it was actually an old redirect that was turned into an article).

@Barkeep49 What filters do you have applied to your feed? E.g. state: unreviewed, type: redirects, etc. You can just take a screenshot if that's easier. That's my best guess.. that some filters aren't being applied when determining what article the "next" button goes to.

@MusikAnimal At the moment the feed is working correctly for me as well with an article from 2005. Before opening this phab ticket I was able to confirm that at lease one other user, @Elmidae was experiencing the same issue

I am happy to screenshot this if/when the problem returns.

Niharika closed this task as Invalid.May 1 2019, 10:40 PM

@Barkeep49 Please reopen this ticket if the problem returns. Thank you!