Page MenuHomePhabricator

Structured Data table overflows when wikidata label is too long
Closed, ResolvedPublic

Description

Reproduction:

  1. set interface language as Polish
  2. go to https://commons.wikimedia.org/wiki/File:Cerkiew_bazylian%C3%B3w_Supra%C5%9Bl.jpg?uselang=pl
  3. click Structured Data tab

Event Timeline

Yarl created this task.Apr 25 2019, 2:44 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 25 2019, 2:44 PM
Ramsey-WMF triaged this task as Normal priority.May 2 2019, 6:47 PM

@PDrouin-WMF I can't recall if we actually did finalize design rules for this. Ellipses after a certain character count?

Well, we're planning on having label text wrap for mobile, can we do the same here?

Well, we're planning on having label text wrap for mobile, can we do the same here?

I think so. I wonder how that'll work with RTL though. But wrap is how Wikidata does it currently.

RTL handling is up in the air regardless -- I'd rather us stay in keeping with Wikidata and wrap text than hide it.

Ramsey-WMF assigned this task to Cparle.May 6 2019, 6:24 PM
Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.

^ looks like word wrap it shall be :)

Ramsey-WMF reassigned this task from Cparle to egardner.May 20 2019, 4:38 PM
Ramsey-WMF added a subscriber: Cparle.

I'm pretty sure that some of the recent mobile-related patches we have merged on master will fix this once we deploy a new release.

Here's what I have in my local development environment, running the latest version of our extension (I set my interface language to Polish to approximate):

The long label text wraps, and no elements overflow outside of the container.

matthiasmullie added a subscriber: matthiasmullie.

Yes, should be fixed already. Moving to Needs QA for verification.

Actually, let's move this to "Verify on Production", since there's nothing new to test, and the example (and fix) are already in prod.

Ramsey-WMF closed this task as Resolved.Jun 3 2019, 11:26 PM

Tested on Production and confirmed to be working.