Page MenuHomePhabricator

WMHack19: TechCom office hour, live edition
Closed, ResolvedPublic

Description

Meet the Wikimedia Technical Committee.

Ask us what you have always wanted to know, tell us what you have always wanted to tell us, discuss the topic you have always wanted top discuss. If you are not at the hackathon, you can join the office hour on Google Meet (no google account required).

To get an idea of what TechCom is doing, have a look at the TechCom board, and read out charter.

Some recent activity:

See also:

  • IRC log of the last (and so far only) TechCom office hour.

Event Timeline

daniel created this task.May 8 2019, 5:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2019, 5:12 PM

Hi @daniel can you provide some links, background & current issues being work on for the TechCom?

daniel updated the task description. (Show Details)May 14 2019, 8:22 PM

Hi @daniel can you provide some links, background & current issues being work on for the TechCom?

I updated the description with some more context. Does this help?

daniel claimed this task.May 14 2019, 8:22 PM
Krinkle moved this task from Inbox to In progress on the TechCom board.May 15 2019, 6:14 PM
daniel updated the task description. (Show Details)May 15 2019, 8:49 PM
TK-999 added a subscriber: TK-999.May 16 2019, 11:11 AM
Tgr awarded a token.May 16 2019, 12:16 PM
Tgr added a subscriber: Tgr.
daniel updated the task description. (Show Details)May 17 2019, 8:10 AM
daniel updated the task description. (Show Details)

@daniel: Did this session take place? If it did, please feel free to create any potential follow-up tasks and set the status of this task to "Resolved" via the Add Action...Change Status dropdown. Thanks a lot!

daniel closed this task as Resolved.May 24 2019, 11:29 AM

The session took place.

It was intended as a loose conversation with no objective besides TechCom members being around for a chat.

The key topic, in my mind, was how to involve more people in TechCom processes, and how to involve more people outside the WMF in these processes, without growing the committee itself beyond the point where it can function efficiently.

The idea of a "Tech Forum" was floated: a group (mostly, a mailing-list) of people interested in being consulted about RFCs and other TechCom activities (rather than being committed, like the committee members). The main difference from the general public, which is of course also consulted about RFCs, is the frequency and volume of communication, and the expectation of feedback. The idea is that the "Tech Forum" would include key stakeholders of technical decisions and people in technical leadership roles, within and outside the WMF.