Page MenuHomePhabricator

Special:ProblemChanges on several Wiktionary sites show raw message IDs instead of translated strings
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

Actual Results:

Event Timeline

Yarl created this task.May 22 2019, 2:27 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 22 2019, 2:27 PM
Aklapper renamed this task from Special:ProblemChanges on pl.wiktionary.org is showing codes instead of values to Special:ProblemChanges on several Wiktionary sites show raw message IDs instead of translated strings.May 22 2019, 2:39 PM
Aklapper triaged this task as Unbreak Now! priority.
Aklapper added a project: Regression.
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMay 22 2019, 2:39 PM
Aklapper added a subscriber: Legoktm.

Thanks for reporting this!

Also happens on other sites using FlaggedRevs. Tentatively marking this as a deployment blocker (please correct if my assessment is wrong).

Wondering if this could be related to https://gerrit.wikimedia.org/r/plugins/gitiles/mediawiki/extensions/FlaggedRevs/+/bab8ea77c7020795cd813cc390e3cbb03ccbb9fd hence CC'ing @Legoktm

Looks like this deployment also has other FlaggedRevs issues according to T220731#5204356

Any progress here?

@Agusbou2015: No, otherwise it would be listed here, plus keep in mind that there are timezones. Also see the other task where you added the same comment.
Not sure what your expectations are based on, asking 42 minutes after this issue got reported here? The page is still functional, as far as I can tell?

hashar added a subscriber: hashar.May 22 2019, 4:08 PM

That might be related to T224116. There is also bab8ea77c7020795cd813cc390e3cbb03ccbb9fd

https://de.wikipedia.org/wiki/Special:ProblemChanges is not affected but is not yet on 1.34.0-wmf.6

https://en.wikinews.org/wiki/Special:ProblemChanges is affected.

So I guess its time to rollback :(

Mentioned in SAL (#wikimedia-operations) [2019-05-22T16:17:00Z] <hashar@deploy1001> rebuilt and synchronized wikiversions files: Revert group1 to 1.34.0-wmf.5 T224116 T224124 # T220731

https://en.wikinews.org/wiki/Special:ProblemChanges and https://pl.wiktionary.org/wiki/Specjalna:W%C4%85tpliwe_zmiany no more shows the issue after moving back to MediaWiki 1.34.0-wmf.5

So we have to find out why the localisation strings have not been included. But I am pretty sure it is for the same reason as T224116 (extension registry being broken). Lets follow up on T224116.

Mentioned in SAL (#wikimedia-operations) [2019-05-22T18:35:07Z] <jforrester@deploy1001> Synchronized php-1.34.0-wmf.6/extensions/FlaggedRevs: Hot-deploy reverting FlaggedRevs config for T224116 T224124 (duration: 00m 58s)

Theoretically fixed (but not rolled out to group1 yet).

Mentioned in SAL (#wikimedia-operations) [2019-05-22T18:53:36Z] <jforrester@deploy1001> Started scap: Re-build i18n and re-scap everything for i18n issues for T224116 T224124 T220731

Mentioned in SAL (#wikimedia-operations) [2019-05-22T19:26:31Z] <jforrester@deploy1001> Finished scap: Re-build i18n and re-scap everything for i18n issues for T224116 T224124 T220731 (duration: 32m 55s)

hashar closed this task as Resolved.May 23 2019, 8:51 AM
hashar assigned this task to SBisson.
hashar added a subscriber: SBisson.

Fixed by @SBisson that reverted FlaggedRevs extension.json for T224116
@Jdforrester-WMF also took care of rebuilding i18n messages.

I have upgraded the wikis, they seem fine now :]