Page MenuHomePhabricator

Visual editor is not compatible with Modern skin
Closed, DuplicatePublic

Description

Dear Sir / Madam,

I am from zhwikiversity. There is user feedback that using modern skin, they are only able to use source editing not VE. The button isn't there. If there are no wikidata item, adding other language will remain grey. I checked with local IA, and confirmed it's nothing we can do by tweaking mediawiki namespace locally. Could you look into the problems. Thanks a lot.

Link to Village pump,
https://zh.wikiversity.org/wiki/Wikiversity:%E4%BA%92%E5%8A%A9%E5%AE%A2%E6%A0%88#%E7%8E%B0%E4%BB%A3%E7%9A%AE%E8%82%A4%E4%B8%8B%E7%9A%84bug

Best Regards,
Cohaf
(P.s. my 1st ticket, pardon if anything screw up)

Event Timeline

Cohaf created this task.Jul 7 2019, 4:24 PM
Restricted Application added subscribers: Cosine02, Aklapper. · View Herald TranscriptJul 7 2019, 4:24 PM
Aklapper changed the task status from Open to Stalled.Jul 7 2019, 6:53 PM

Hi @Cohaf, thanks for taking the time to report this and welcome to Wikimedia Phabricator!

Cannot reproduce the problem when going to the random page https://zh.wikiversity.org/wiki/计算机技术?useskin=modern : I see both 编辑 and 编辑源代码.

Under https://zh.wikiversity.org/wiki/Special:参数设置#mw-prefsection-editing , is 暂时禁用正在测试中的可视化编辑器 disabled?

Could you add a screenshot if possible? Thanks.

There is user feedback that using modern skin, they are only able to use source editing not VE.
The button isn't there. If there are no wikidata item, adding other language will remain grey.

These are two different problems? Please follow https://www.mediawiki.org/wiki/How_to_report_a_bug : "Include only one problem per task"

Hi @Cohaf, thanks for taking the time to report this and welcome to Wikimedia Phabricator!

Cannot reproduce the problem when going to the random page https://zh.wikiversity.org/wiki/计算机技术?useskin=modern : I see both 编辑 and 编辑源代码.

Under https://zh.wikiversity.org/wiki/Special:参数设置#mw-prefsection-editing , is 暂时禁用正在测试中的可视化编辑器 disabled?

Could you add a screenshot if possible? Thanks.

Hello, please change your appearance into Modern or 现代 or 現代 (I don't know what it would be in English interface), then go to a page and click 編輯, it will not go to VE but original page. I believe it is what Cohaf said.

Cohaf added a comment.Jul 8 2019, 6:48 AM

Sorry I'm late. Thanks my colleagues who replied above. It's what they said. As of the wikidata bug, I'll file separately when I have more info. Thanks all.

Xiplus renamed this task from Bug for Editing in zhwikiveristy using modern skin to Visual editor is not loaded on zhwikiveristy with modern skin.Jul 8 2019, 7:00 AM
Hamishcn renamed this task from Visual editor is not loaded on zhwikiveristy with modern skin to Visual editor is not loaded on zhwikiverisity with modern skin.Jul 8 2019, 7:04 AM

Visual editor is not supposed to be compatible with the Modern skin: https://www.mediawiki.org/wiki/Extension:VisualEditor#Skin_compatibility

Visual editor is not supposed to be compatible with the Modern skin: https://www.mediawiki.org/wiki/Extension:VisualEditor#Skin_compatibility

https://zh.wikiversity.org/wiki/Special:%E7%89%88%E6%9C%AC shows zhwikiversity is at MediaWiki 1.34.

Aklapper renamed this task from Visual editor is not loaded on zhwikiverisity with modern skin to Visual editor is not compatible with Modern skin.Jul 13 2019, 8:34 AM
Aklapper changed the task status from Stalled to Open.
Viztor added a subscriber: Viztor.Jul 19 2019, 2:41 PM

Visual editor is not supposed to be compatible with the Modern skin: https://www.mediawiki.org/wiki/Extension:VisualEditor#Skin_compatibility

https://zh.wikiversity.org/wiki/Special:%E7%89%88%E6%9C%AC shows zhwikiversity is at MediaWiki 1.34.

Does that mean VE is compatible with all skins as of the latest version?

Does that mean VE is compatible with all skins as of the latest version?

No.

Cohaf added a comment.Feb 29 2020, 7:32 PM

Hello,

No updates since Jul. Is it a yes or a no? Or what is the status of adding the button to the skin now? I know this is sort of low priority but is there any news.

Thanks so much and regards,
CM

No updates since Jul. Is it a yes or a no?

@Cohaf: "yes or no" as answers to which question exactly? :) See T227410#5315860 for the current status. Anyone is free to investigate how to potentially fix this.

Cohaf added a comment.Mar 2 2020, 3:08 PM

No updates since Jul. Is it a yes or a no?

@Cohaf: "yes or no" as answers to which question exactly? :) See T227410#5315860 for the current status. Anyone is free to investigate how to potentially fix this.

@Aklapper Thanks for your explanation. So it's the skin compatibility issue. Will report back.

Cohaf closed this task as Resolved.Mar 3 2020, 4:39 PM
Cohaf claimed this task.

Closed per Local discussion. Since skin compatibility issues needs long time to resolve, we won't pursue this as a phab ticket anymore.

matmarex changed the task status from Resolved to Declined.Mar 3 2020, 7:17 PM
Shizhao moved this task from Backlog to Closed on the Chinese-Sites board.Mar 5 2020, 7:24 AM