Page MenuHomePhabricator

No loading progress shown when switching from mobile wikitext to mobile VE
Closed, ResolvedPublic

Description

Open switcherChoose visualSurface goes blankVE finishes loading

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterEditorOverlayBase: Fix spinner icon
mediawiki/extensions/MobileFrontend : masterFix truncating text with ellipsis in overlay headers

Event Timeline

Esanders created this task.Jul 15 2019, 7:37 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptJul 15 2019, 7:37 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Esanders updated the task description. (Show Details)Jul 15 2019, 7:41 PM

We didn't really design for this case, but I would guess showing the * Editor loading spinner would suffice.

Ideally we'd grey out the wikitext surface instead of hiding it too, and change the copy to "Switching editor":

matmarex claimed this task.Jul 15 2019, 8:19 PM

This is caused by rEMFRbd1b16ff18bc: Get rid of toHtmlString and simplify overlay header construction. Previously, a generic spinner would be shown when switching editors.

Switching……from source to visual…from visual to source
Before
After

(The same change has also apparently broke the ellipsing of page title in wikitext editor.)

Change 523305 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] Fix truncating text with ellipsis in overlay headers

https://gerrit.wikimedia.org/r/523305

Change 523306 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] EditorOverlayBase: Fix spinner icon

https://gerrit.wikimedia.org/r/523306

Change 523305 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Fix truncating text with ellipsis in overlay headers

https://gerrit.wikimedia.org/r/523305

Change 523306 merged by Jdlrobson:
[mediawiki/extensions/MobileFrontend@master] EditorOverlayBase: Fix spinner icon

https://gerrit.wikimedia.org/r/523306

matmarex moved this task from Inbox to High Priority on the Editing QA board.Jul 15 2019, 11:31 PM

Nice catch @Esanders

The fix here should mirror the flow for the loading indicator when getting into Visual Editor.

We just fixed the regression, so it looks like it did before:

Making it look more like the VE loader should be added to our Q1 usability task list.

Ryasmeen edited projects, added Verified; removed Editing QA.Jul 26 2019, 3:00 PM
Ryasmeen moved this task from QA to Product owner review on the VisualEditor (Current work) board.
ppelberg closed this task as Resolved.Sep 3 2019, 12:06 AM