Page MenuHomePhabricator

Requesting access to machines [stat1004, stat1007, stat1006, notebook1003 and notebook1004] and groups for cchen
Closed, ResolvedPublic

Description

Wikitech username: conniecc1
preferred shell username: cchen
developer access username / Instance shell account name in preferences: cchen
Full name: Connie Chen

REQUEST: I will need access to machines [stat1004, stat1007, stat1006, notebook1003 and notebook1004] and to be added to these groups: analytics-wmde, analytics-privatedata-users, and researchers

REASONING: New data analyst start from 7/17 for product analytics team. Need access for data source and notebooks.

VERIFICATION: verified by my manager @kzimmerman

Thank you!

ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIKGn8ICH7EqpRV1ADQ9xBZki5AzMlMAbvpGv/3becvam cchen@Connies-MacBook-Pro.local

SRE Clinic Duty Checklist for New Shell Access Requests

Most requirements are outlined on https://wikitech.wikimedia.org/wiki/Requesting_shell_access

This checklist should be used on all access requests to ensure that all steps are covered. This includes expansion to access. Please do not check off items on the list below unless you are in Ops and have confirmed the step.

  • - User has signed the L3 Acknowledgement of Wikimedia Server Access Responsibilities Document.
  • - User has a valid NDA on file with WMF legal. (This can be checked by Operations via the NDA tracking sheet & is included in all WMF Staff/Contractor hiring.)
  • - User has provided the following: wikitech username, preferred shell username, email address, and full reasoning for access (including what commands and/or tasks they expect to perform.
  • - User has provided a public SSH key. This ssh key pair should only be used for WMF cluster access, and not share with any other service (this includes not sharing with WMCS access, no shared keys.)
  • - access request (or expansion) has sign off of WMF sponsor/manager (sponser for volunteers, manager for wmf staff)
  • - 3 business day wait must pass with no objections being noted on the task
  • - both sudo and non sudo group additions are approved by the manager/team that handles that service group. - pending approval from @Nuria
  • - Patchset for access request - https://gerrit.wikimedia.org/r/525578

Event Timeline

cchen created this task.Jul 18 2019, 4:30 PM
Restricted Application added a project: Operations. · View Herald TranscriptJul 18 2019, 4:30 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Approved as Connie's manager, thanks!

@RStallman-legalteam can you verify that Connie has signed the appropriate NDAs?

@kzimmerman this will be similar to the last case where I'll need to create one for legal because of the specializes access. Could you pass me Connie's email address and I'll get it done. Thanks!

Emailed; thanks Rachel!

Updating again as I looked into this and no special NDA is needed in this case. Fine to proceed. Thanks!

fsero added a subscriber: fsero.Jul 19 2019, 5:12 AM

@cchen as stated in https://wikitech.wikimedia.org/wiki/Production_shell_access we need your public SSH key, this key shouldn't be the same you use to access gerrit or WMCS.

This will move forward the moment you provide one :)

fsero triaged this task as Normal priority.Jul 19 2019, 5:12 AM
cchen updated the task description. (Show Details)Jul 19 2019, 8:45 PM
cchen added a comment.EditedJul 19 2019, 9:21 PM

Thanks for the info! Just updated my SSH key in description.

Change 525578 had a related patch set uploaded (by Herron; owner: Herron):
[operations/puppet@production] add conniecc1 to analytics-(wmde|privatedata)-users,researchers group

https://gerrit.wikimedia.org/r/525578

Looping in @Nuria for analytics review/approval

RobH updated the task description. (Show Details)Jul 30 2019, 7:37 PM
RobH assigned this task to cchen.Jul 30 2019, 7:39 PM
RobH added a subscriber: RobH.

@cchen,

Please note we will need you to review and sign the L3 document. Once done, if @Nuria has not attached approval, assign to @Nuria.

Otherwise this is awaiting @Nuria's approval for inclusion into groups they administer.

Once all the above is done, just set to no assignee and I'll pick it up with clinic duty.

RobH updated the task description. (Show Details)Jul 30 2019, 7:40 PM
RobH updated the task description. (Show Details)
cchen reassigned this task from cchen to Nuria.Jul 31 2019, 9:20 PM
cchen updated the task description. (Show Details)
Nuria added a comment.Jul 31 2019, 9:26 PM

Approved on my end once employment is verified.

kzimmerman removed Nuria as the assignee of this task.Aug 1 2019, 4:10 PM

I've approved as manager, so moving back to unassigned for @RobH/clinic duty to pick up. (Let me know if there's anything else I need to provide.)

kzimmerman updated the task description. (Show Details)Aug 7 2019, 6:03 PM

Updated ticket to reflect 3 business days passing and approval from Nuria. @RobH can you provide the patch or let us know who's on clinic duty?

Thank you!

Sorry, I see that I should not have checked off those items - unchecking them!

kzimmerman updated the task description. (Show Details)Aug 7 2019, 6:05 PM
RobH added a subscriber: colewhite.Aug 7 2019, 6:06 PM

Updated ticket to reflect 3 business days passing and approval from Nuria. @RobH can you provide the patch or let us know who's on clinic duty?
Thank you!

Clinic duty is posted each week in the #wikimedia-operations channel or on https://wikitech.wikimedia.org/wiki/SRE_Clinic_Duty

This week is @colewhite

colewhite updated the task description. (Show Details)Aug 7 2019, 11:37 PM
colewhite updated the task description. (Show Details)

Change 525578 merged by Cwhite:
[operations/puppet@production] add conniecc1 to analytics-(wmde|privatedata)-users,researchers group

https://gerrit.wikimedia.org/r/525578

colewhite closed this task as Resolved.Aug 8 2019, 3:29 PM
colewhite claimed this task.
colewhite updated the task description. (Show Details)

Group membership change has been deployed.

Please feel free to reopen if you encounter any related issues.

cchen added a comment.Aug 9 2019, 8:21 PM

Thank you @colewhite!

I am still having trouble to log into Superset and Turnilo using my wikitech account. Can you help me with this? Thanks again!

cchen reopened this task as Open.Aug 9 2019, 8:22 PM

Access to Superset and Turnilo are managed by the 'wmf' LDAP group. Since it is beyond the scope of this task, your new access request can be found here: T230242

colewhite closed this task as Resolved.Aug 9 2019, 9:11 PM
cchen reopened this task as Open.Aug 13 2019, 3:01 PM
This comment was removed by cchen.
cchen closed this task as Resolved.Aug 13 2019, 3:01 PM