Page MenuHomePhabricator

Monospace template causes the rest of the paragraph to be ignored
Closed, ResolvedPublic

Description

When the source content includes a Mono or Monospace Template (Monospace is just a redirect of Mono) , adding it to the translation tends to ignore the contents after it.

This page compiles several examples, and you can use this quick link to test how these get cut when translating. The screenshot below shows the example for an English-to-Spanish translation where the contents after the monospace "php5apache2.dll" got lost when added to the translation, and highlight suggests that the monospace element breaks the segmentation of the contents:


This was based on this user comment.

Event Timeline

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJul 19 2019, 8:56 AM
Pginer-WMF triaged this task as Medium priority.Jul 19 2019, 9:11 AM
Pginer-WMF updated the task description. (Show Details)
Pginer-WMF lowered the priority of this task from Medium to Low.Jul 29 2019, 11:31 AM
Pginer-WMF raised the priority of this task from Low to Medium.Jul 29 2019, 11:49 AM

Assuming Apertium was the MT engine used.

When I tried, this was the result:

Apertium is plain text MT engine and has limiations in transfering markup on top of translation. So just like references were moved to the end, the template for monospace also moves to the end. I don't see an issue of ignoring any content.

Pginer-WMF closed this task as Resolved.Aug 19 2019, 9:39 AM
Pginer-WMF claimed this task.

I tried to reproduce with different MT services and the issue is no longer happening. It may have been solved as a side effect of other changes in the area.