Page MenuHomePhabricator

Inform AMC users that grouped results are not available on the recent changes page
Closed, ResolvedPublic3 Story Points

Description

Background

We're disabling grouped results on recent changes and would like to have a way to let users know the functionality is missing

Acceptance Criteria

  • Use
<div class="warningbox">
	-----COPY FOR NOTICE-----
</div>

Copy: "Unfortunately, grouping results by page is not available on mobile. If you would like to use the group by page feature please visit the desktop site."

  • Show on the Minerva skin for users who have the "grouped" view preference turned on, or when the enhanced=1 URL param is present.
  • Banner should not show on Vector

Developer notes

To do this we'll need to make use of a hook (the special page is defined in core) and only add it for Minerva skin.
The existing hook function onSpecialPageBeforeExecute inside Minerva is probably the best place to add this although will give us limited control over where the banner goes (it places it after the title).

@alexhollender has confirmed location is okay:

Only showing it to users where it's disable will require duplicating some logic in core - checking if the feature is enabled e.g. via user or request query parameter and whether the skin is minerva

QA Steps

Environment: Beta cluster
mobile mode: AMC
user permissions: logged in & anonymous

  • As a logged-in user, I set my user preference (link here on beta cluster) to enable "Group changes by page in recent changes and watchlist". With this setting on, when I visit the recent changes page on mobile, I should see a banner informing me that this feature is disabled.
  • As an anonymous and logged-in user, if I'm on the recent changes page on mobile, and I add the URL parameter &enhanced=1 to the end of the URL and refresh the page, I should see a banner informing me that this feature is disabled on mobile.
  • As an anonymous and logged-in user, If I'm on the desktop version of the recent changes page, and I click the option to "Group results by page" in the date-picker, and I switch to mobile mode, I should see the banner that this option is disable on mobile.

Event Timeline

ovasileva triaged this task as High priority.Jul 19 2019, 2:01 PM
ovasileva created this task.
ovasileva moved this task from Incoming to Upcoming on the Readers-Web-Backlog board.
Jdlrobson removed Jdlrobson as the assignee of this task.Jul 22 2019, 4:21 PM
Jdlrobson added a project: MinervaNeue.
Jdlrobson updated the task description. (Show Details)
Jdlrobson added a subscriber: Jdlrobson.
Jdlrobson updated the task description. (Show Details)
Jdlrobson set the point value for this task to 3.
Jdlrobson added a subscriber: Alex.

@Alex please guide us on how to position this banner.

I'm not Alex, but I'll give my 2 cents on the positioning.

On desktop, the "grouped" option can be toggled on and off with a checkbox in the advanced filters.

If we remove this checkbox (for mobile only) then the only way to trigger this view would a be through the URL param enhanced=1 or as a user preference. Both of these actions require a full-page refresh, at which point users are looking at the top of the page anyway. So IMO, I think the banner on top is fine.

Also I also hope we can style this banner as "warning" rather than an "error".

Jdrewniak updated the task description. (Show Details)Jul 29 2019, 1:35 PM
Jdrewniak updated the task description. (Show Details)

Top of the page sounds good to me.

@Jdrewniak my only other thought would be to put it closer to the list of changes, since that's the relevant context in a way. Though I'm not sure where it's more likely to be noticed. Since you've been working on this page quite a bit I leave it to your discretion.

Jdlrobson updated the task description. (Show Details)Jul 29 2019, 10:13 PM
Jdlrobson removed Jdlrobson as the assignee of this task.Jul 30 2019, 11:18 PM

sorry got distracted by deploying the click tracking. Someone please pick up if I don't tomorrow :)

Change 526698 had a related patch set uploaded (by Pmiazga; owner: Pmiazga):
[mediawiki/skins/MinervaNeue@master] Show warning when user tries to use enhanced RecentChanges view

https://gerrit.wikimedia.org/r/526698

pmiazga removed pmiazga as the assignee of this task.Jul 31 2019, 3:08 PM

Change 526698 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Show warning when user tries to use enhanced RecentChanges view

https://gerrit.wikimedia.org/r/526698

brennen raised the priority of this task from High to Unbreak Now!.Jul 31 2019, 6:57 PM

Changing priority to UBN!, as this is listed as a train blocker.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptJul 31 2019, 6:57 PM
Jdlrobson lowered the priority of this task from Unbreak Now! to Normal.Jul 31 2019, 8:14 PM

This one is not a train blocker. Just T228280. Have updated the relationship. They are related tasks but this shouldn't have been a subtask.

Jdrewniak reassigned this task from Jdrewniak to Edtadros.Aug 5 2019, 11:32 AM
Jdrewniak updated the task description. (Show Details)
ovasileva claimed this task.Aug 6 2019, 3:20 PM
ovasileva reassigned this task from ovasileva to Edtadros.
ovasileva claimed this task.
ovasileva added a subscriber: Edtadros.
ovasileva reassigned this task from ovasileva to alexhollender.EditedAug 6 2019, 5:32 PM

Looks good:

QA Steps

Environment: Beta cluster
mobile mode: AMC
user permissions: logged in & anonymous

  • As a logged-in user, I set my user preference (link here on beta cluster) to enable "Group changes by page in recent changes and watchlist". With this setting on, when I visit the recent changes page on mobile, I should see a banner informing me that this feature is disabled.

  • As an anonymous and logged-in user, if I'm on the recent changes page on mobile, and I add the URL parameter &enhanced=1 to the end of the URL and refresh the page, I should see a banner informing me that this feature is disabled on mobile.
  • As an anonymous and logged-in user, If I'm on the desktop version of the recent changes page, and I click the option to "Group results by page" in the date-picker, and I switch to mobile mode, I should see the banner that this option is disable on mobile.
alexhollender closed this task as Resolved.Aug 7 2019, 7:54 PM
alexhollender removed alexhollender as the assignee of this task.
alexhollender updated the task description. (Show Details)

re-confirming that the banner shows in all cases listed above in the QA steps section.