Page MenuHomePhabricator

Drop support for MSSQL and Oracle from core
Closed, ResolvedPublic

Description

As it has been decided in the RFC (T191231: RFC: Abstract schemas and schema changes).

Details

Related Gerrit Patches:
mediawiki/core : masterRemove $wgDBWindowsAuthentication
mediawiki/core : masterRemove Oracle reference from WikiMap
mediawiki/core : masterDrop Oracle and Mssql
mediawiki/core : masterRemove more Oracle and Mssql leftovers
mediawiki/core : masterAdd drop of mssql/oracle to RELEASE-NOTES
mediawiki/core : masterMore clean up of oracle/mssql
mediawiki/core : masterDrop Mssql

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 13 2019, 2:50 PM

Change 529978 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/core@master] Drop Oracle

https://gerrit.wikimedia.org/r/529978

Change 529984 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/core@master] Drop Mssql

https://gerrit.wikimedia.org/r/529984

Change 529984 abandoned by Ladsgroup:
Drop Mssql

Reason:
Done by I90bd5cfcc3e18011b193c965fdb1fa54675040b5

https://gerrit.wikimedia.org/r/529984

Reedy updated the task description. (Show Details)Aug 14 2019, 11:30 AM
Reedy updated the task description. (Show Details)
Reedy assigned this task to Ladsgroup.Aug 14 2019, 11:35 AM
Reedy added a subscriber: Reedy.

Needs RELEASE-NOTES to complete this task, but core patch CR+2'd as per https://phabricator.wikimedia.org/T191231#5411308

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptAug 14 2019, 11:35 AM

Change 529978 merged by jenkins-bot:
[mediawiki/core@master] Drop Oracle and Mssql

https://gerrit.wikimedia.org/r/529978

Change 530166 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/core@master] More clean up of oracle/mssql

https://gerrit.wikimedia.org/r/530166

Change 530166 merged by jenkins-bot:
[mediawiki/core@master] More clean up of oracle/mssql

https://gerrit.wikimedia.org/r/530166

Change 530206 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/core@master] Add drop of mssql/oracle to RELEASE-NOTES

https://gerrit.wikimedia.org/r/530206

Change 530206 merged by jenkins-bot:
[mediawiki/core@master] Add drop of mssql/oracle to RELEASE-NOTES

https://gerrit.wikimedia.org/r/530206

Ladsgroup closed this task as Resolved.Aug 15 2019, 8:29 AM
Aklapper added a comment.EditedAug 15 2019, 11:13 AM

Is there any documented guideline for third-party administrators who use Oracle or MSSQL as their backend and want to upgrade to 1.34?

Should https://phabricator.wikimedia.org/T113831 be closed as a duplicate of this task?

Change 530355 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/core@master] Kill oracle and mssql leftovers

https://gerrit.wikimedia.org/r/530355

Change 530359 had a related patch set uploaded (by Aaron Schulz; owner: Aaron Schulz):
[mediawiki/core@master] Remove Oracle reference from WikiMap

https://gerrit.wikimedia.org/r/530359

Change 530355 merged by jenkins-bot:
[mediawiki/core@master] Remove more Oracle and Mssql leftovers

https://gerrit.wikimedia.org/r/530355

Change 530359 merged by jenkins-bot:
[mediawiki/core@master] Remove Oracle reference from WikiMap

https://gerrit.wikimedia.org/r/530359

Change 550014 had a related patch set uploaded (by Mainframe98; owner: Mainframe98):
[mediawiki/core@master] Remove $wgDBWindowsAuthentication

https://gerrit.wikimedia.org/r/550014

Maintenance_bot moved this task from Incoming to Done on the User-Ladsgroup board.Nov 10 2019, 3:15 PM

Change 550014 merged by jenkins-bot:
[mediawiki/core@master] Remove $wgDBWindowsAuthentication

https://gerrit.wikimedia.org/r/550014