Page MenuHomePhabricator

Lake Huron missing due to apparent OSM vandalism
Closed, ResolvedPublic

Description

Lake Huron has gone missing on Wikimedia maps: https://maps.wikimedia.org/#7/44.674/-82.213

I assume this is due to OpenStreetMap vandalism. Everything looks fine over there now: https://www.openstreetmap.org/search?query=Lake%20Huron#map=7/44.674/-82.213

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 30 2019, 10:04 PM
MusikAnimal updated the task description. (Show Details)Aug 30 2019, 10:06 PM

Mentioned in SAL (#wikimedia-operations) [2019-08-30T22:09:49Z] <gehel> regenerating tiles around Lake Huron for maps eqiad / codfw - T231691

OSM replication was triggered manually and tile generation started for that area (follow the generation on grafana). If that's enough, we'll just need to invalidate cache for that area, or wait 24h for cache invalidation. If that did not fix the issue, we'll need more investigation. Either we have corrupted data in some way (on both eqiad and codfw, seems unlikely) or we have a style issue.

I failed to mention that if you zoom in far enough, you'll see water https://maps.wikimedia.org/#12/44.7640/-82.1264. It seems only the tiles on zoom level 8 or lower are affected.

Gehel added a comment.Sep 1 2019, 7:58 AM

As far as I can tell, the issue is now resolved.

@MusikAnimal can you confirm and close this ticket if all looks good to you?

Thanks!

Pikne added a subscriber: Pikne.Sep 1 2019, 10:40 AM

@Gehel, there's also a lake in Norway waiting for monthly automatic update to reappear in smaller zoom levels (T230511). What are the guidelines on how should users report such issues so that they would get fixed reasonably quickly?

MSantos added a subscriber: MSantos.Sep 2 2019, 5:47 PM

Mentioned in SAL (#wikimedia-operations) [2019-09-02T17:57:14Z] <mateusbs17> regenerating tiles from z0 to z9 in eqiad and codfw- T231691, T230511

Haros added a subscriber: Haros.Sep 3 2019, 12:27 PM

@Gehel, there's also a lake in Norway waiting for monthly automatic update to reappear in smaller zoom levels (T230511). What are the guidelines on how should users report such issues so that they would get fixed reasonably quickly?

Now the tiny lake in Africa - Lake Victoria - suffers from the same problem. We really need a way to trigger a refresh without creating a new issue. I can do so if that is necessary, but it should not be.

Gehel added a comment.Sep 3 2019, 12:55 PM

We really need a way to trigger a refresh without creating a new issue. I can do so if that is necessary, but it should not be.

It looks like a new feature request (which definitely make sense!). This should be added to the maps backlog and prioritized in some way. @MSantos : could you have a look? Any idea how feasible this is?

MusikAnimal closed this task as Resolved.Sep 3 2019, 1:59 PM
MusikAnimal claimed this task.

As far as I can tell, the issue is now resolved.
@MusikAnimal can you confirm and close this ticket if all looks good to you?
Thanks!

Confirmed, thank you!

We really need a way to trigger a refresh without creating a new issue. I can do so if that is necessary, but it should not be.

It looks like a new feature request (which definitely make sense!). This should be added to the maps backlog and prioritized in some way. @MSantos : could you have a look? Any idea how feasible this is?

I created the phab ticket and added some of you as subscribers, but some open questions should be discussed as a community before digging it further, see T231885: [FEATURE REQUEST] - Create a way to trigger tile refresh when OSM is vandalized

I am currently seeing Lake Huron entirely white on most zooms, and with some white tiles on zooms above 9. (on Wikimedia maps: https://maps.wikimedia.org/#7/44.674/-82.213 and across various implementations of maplink, and graph templates). Is this a cache issue from last time or has the problem re-emerged? @Gehel was able to do an OSM replication last time. Did that resolve it, and how has it returned? It looks fine on the OSM site.