title/tooltip missing on file with empty link
Closed, ResolvedPublic

Description

Files without a link ([[File:Wiki.png|link=|description]]) has no tooltips in FireFox, but in IE7.

IE7 shows the alt-attribut when hover over the file. FireFox shows only title-attributs. By linked files that title-attribut came from the a-tag, by unlinked files it is missing.

Please add a title-attribut to the img-tag of unlinked files, so FireFox can show a tooltip. Thanks.


Version: unspecified
Severity: normal

Details

Reference
bz21454
bzimport set Reference to bz21454.
bzimport added a subscriber: Unknown Object (MLST).
  • Bug 24572 has been marked as a duplicate of this bug. ***
  • Bug 30110 has been marked as a duplicate of this bug. ***
hoo added a comment.Aug 19 2013, 3:27 PM

(In reply to comment #0)

Please add a title-attribut to the img-tag of unlinked files, so FireFox can
show a tooltip. Thanks.

What value should that title attribute take in your opinion? The given description? The alt text?

(In reply to comment #3)

What value should that title attribute take in your opinion? The given
description? The alt text?

The caption, or the alt= value.

Note that blanking the link attribute is recommended per [[:en:WP:ICON]] and
[[:en:WP:ALT]] guidelines for accessibility reasons.

Change 153353 had a related patch set uploaded by Jackmcbarn:
Always set a title on images when provided

https://gerrit.wikimedia.org/r/153353

Change 153353 had a related patch set uploaded (by Cscott):
Always set a title on images when provided

https://gerrit.wikimedia.org/r/153353

Patch-For-Review

Change 153353 merged by jenkins-bot:
Always set a title on images when provided

https://gerrit.wikimedia.org/r/153353

Umherirrender closed this task as "Resolved".Dec 12 2014, 7:39 PM
Umherirrender claimed this task.
Ciencia_Al_Poder reassigned this task from Umherirrender to Jackmcbarn.
Ciencia_Al_Poder set Security to None.
Ciencia_Al_Poder added a subscriber: Ciencia_Al_Poder.
Ciencia_Al_Poder removed a subscriber: Unknown Object (MLST).

Add Comment