Page MenuHomePhabricator

Transition of MF expand icons when opening VE is wrong after icon updates
Closed, ResolvedPublic

Description

After animation:


After switching to VE:

Details

Related Gerrit Patches:

Event Timeline

Esanders created this task.Oct 16 2019, 6:39 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 16 2019, 6:39 PM
Esanders updated the task description. (Show Details)Oct 16 2019, 6:42 PM

Change 543542 had a related patch set uploaded (by Bartosz Dziewoński; owner: Esanders):
[mediawiki/extensions/MobileFrontend@master] mobile.init/editor: Fix transition of collapse icon after icon changes

https://gerrit.wikimedia.org/r/543542

Change 543542 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] mobile.init/editor: Fix transition of collapse icon after icon changes

https://gerrit.wikimedia.org/r/543542

@Esanders/@matmarex: Great that we fixed this, but could you please tell me what are the things that I need to check here.

When you load the editor the ^ icon should slide out of view. Once the editor has finished loading there should be no change in appearance of the heading. Currently the headings jump from having a slight left padding to having none.

When you load the editor the ^ icon should slide out of view. Once the editor has finished loading there should be no change in appearance of the heading. Currently the headings jump from having a slight left padding to having none.

Got it. So ^ icon is sliding out of view just fine. About the slight animation of having slight left padding then to have none, it seems to me this is still happening on Beta, not sure though. Sharing screen capture of how it behaves both on Beta and Production.

Beta:

Production:

Got it. So ^ icon is sliding out of view just fine. About the slight animation of having slight left padding then to have none, it seems to me this is still happening on Beta, not sure though. Sharing screen capture of how it behaves both on Beta and Production.

Yeah, it definitely is wrong in that Beta video, but I couldn't reproduce this when I tested on Beta just now – the heading was aligned perfectly when it transitioned. I'm not sure if this is a device-specific issue, or if perhaps some change to the mobile site in the meantime fixed it. Can you try again?

Got it. So ^ icon is sliding out of view just fine. About the slight animation of having slight left padding then to have none, it seems to me this is still happening on Beta, not sure though. Sharing screen capture of how it behaves both on Beta and Production.

Yeah, it definitely is wrong in that Beta video, but I couldn't reproduce this when I tested on Beta just now – the heading was aligned perfectly when it transitioned. I'm not sure if this is a device-specific issue, or if perhaps some change to the mobile site in the meantime fixed it. Can you try again?

Yeah, I'm not sure what I'm looking at right now. I don't know how the animation was before fixing this, so I have no reference point. Whatever is happening now is very subtle and I feel we can ignore that.

ppelberg closed this task as Resolved.Dec 24 2019, 6:30 PM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptDec 24 2019, 6:30 PM