Page MenuHomePhabricator

Spike in "Use of ResourceLoaderSkinModule::getAvailableLogos with $wgLogoHD set instead of $wgLogos was deprecated in MediaWiki 1.35."
Closed, ResolvedPublic

Description

Mediawiki appears to have started emitting a significant amount of deprecation messages to logstash, for example:

https://logstash.wikimedia.org/goto/7618b08032132948faa201d3fbe5de33 - "Use of ResourceLoaderSkinModule::getAvailableLogos with $wgLogoHD set instead of $wgLogos was deprecated in MediaWiki 1.35."

Along with this kafka-logging has begun alerting on consumer lag, indicating that logstash is unable to keep up with the volume of log messages.

Can these deprecated messages be quickly disabled?

Event Timeline

herron created this task.Feb 20 2020, 8:51 PM
Restricted Application added subscribers: Liuxinyu970226, Aklapper. · View Herald TranscriptFeb 20 2020, 8:51 PM

Similar to recent issue T245725

elukey triaged this task as High priority.Feb 21 2020, 8:04 AM
elukey added a subscriber: Jdforrester-WMF.
jcrespo added a subscriber: jcrespo.

adding wikimedia production error because at the 3x the rate increase compared to normal levels of logging will soon start to affect monitoring of latest mediawiki errors. Probably not UBN, but starting to get worrying.

Change 573993 had a related patch set uploaded (by Reedy; owner: Jforrester):
[mediawiki/core@wmf/1.35.0-wmf.20] ResourceLoaderSkinModule: Don't hard-deprecate wgLogoHD just now

https://gerrit.wikimedia.org/r/573993

Change 573994 had a related patch set uploaded (by Reedy; owner: Jforrester):
[mediawiki/core@master] ResourceLoaderSkinModule: Don't hard-deprecate wgLogoHD just now

https://gerrit.wikimedia.org/r/573994

Change 573993 merged by Reedy:
[mediawiki/core@wmf/1.35.0-wmf.20] ResourceLoaderSkinModule: Don't hard-deprecate wgLogoHD just now

https://gerrit.wikimedia.org/r/573993

Mentioned in SAL (#wikimedia-operations) [2020-02-21T13:38:15Z] <reedy@deploy1001> Synchronized php-1.35.0-wmf.20/includes/resourceloader/ResourceLoaderSkinModule.php: T245778 T245182 T232140 (duration: 01m 00s)

Change 573994 merged by jenkins-bot:
[mediawiki/core@master] ResourceLoaderSkinModule: Don't hard-deprecate wgLogoHD just now

https://gerrit.wikimedia.org/r/573994

Reedy closed this task as Resolved.Feb 21 2020, 1:44 PM
Reedy claimed this task.

Errors have gone completely. Shouldn't regress again as I've merged it into master too

Thanks @Reedy and @jcrespo ! Not that the issue is less urgent but for the record: this issue is/was affecting only the elk7 consumers (not yet in production, but in shadow mode) cluster=misc exported_cluster=logging-eqiad group=logstash7-eqiad instance=kafkamon1001:9501 job=burrow partition={0,1,2,3,4,5} site=eqiad topic=udp_localhost-info