Page MenuHomePhabricator

Missing "unsubscribe" link in automatic recurring failure email
Closed, ResolvedPublic

Description

Hi team,

Issue with Civi emails, spotted by DS agent Kristine Hancock:

The unsubscribe link is missing from “If you do not wish to receive any future emails from the Wikimedia Foundation, unsubscribe now.” The words are not clickable, so the donor can't actually unsubscribe.

This might be an issue across several emails--might be across the board. I will look myself & update this task as I can.
Thanks!

  • Thea

Event Timeline

TSkaff created this task.Jun 23 2020, 7:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 23 2020, 7:03 PM
TSkaff renamed this task from [High Priority] Missing link "unsubscribe" links in auto-generated Civi emails to [High Priority] Missing "unsubscribe" link in auto-generated Civi emails.Jun 23 2020, 7:20 PM

@TSkaff if this is from an email from the email team, we can't change this. @CCogdill_WMF I'm not sure who all would need to see this.

DStrine renamed this task from [High Priority] Missing "unsubscribe" link in auto-generated Civi emails to Missing "unsubscribe" link in auto-generated Civi emails.Jun 23 2020, 7:33 PM

Which email was this from? I read the title of this task and thought it was referring to a Civi TY email.

TSkaff added a comment.EditedJun 23 2020, 7:39 PM

@DStrine My understanding is that the issue is from some of the auto-generated emails from Civi (not ones that the email team can edit). Such as the new Automated Recurring Restart Email.

Source: DS Feedback doc

DStrine added a comment.EditedJun 23 2020, 7:39 PM

@TSkaff do you know which ones? We could do a scan but it would be helpful if we knew with ones this was originally found in.

DStrine removed DStrine as the assignee of this task.Jun 23 2020, 7:41 PM
DStrine moved this task from Triage to Sprint B Jan 19th to Feb 2nd on the Fundraising-Backlog board.
DStrine added a subscriber: DStrine.
This comment was removed by TSkaff.

@krobinson says "Just FYI the link is not clickable across the board. I did some searches of replies (we have only had a handful) but the unsub link is just text."

Can she provide a sample Zendesk ticket? It should be easy enough to tell
what type of email this is.

@CCogdill_WMF Kristine cited this one: #760801, but Kristie seemed to have found it elsewhere, I'm just not sure where, so I'm looking around.

TSkaff updated the task description. (Show Details)Jun 23 2020, 8:02 PM

Example: Ref CiviRecen_US 582401

More examples can be found in #761358 ; #760858 ; and #760710.

In each of them the unsubscribe link in the footer is just text, and not clickable / hyperlinked.

mepps added a subscriber: mepps.Jun 24 2020, 1:49 PM

I've confirmed these are all the newly added failed recurring emails. We'll need to address it in the data strings template for that.

mepps claimed this task.Jun 24 2020, 1:50 PM
mepps added a comment.Jun 24 2020, 3:04 PM

I have confirmed that the html message we imported didn't have the unsubscribe link. I just need to confirm how to get that then we'll update the html_message.

mepps added a comment.Jun 24 2020, 3:38 PM

Right now, I can find the unsub link in the thank_you drupal module and it's generated by a variable. I'm wondering if we ever get it in civi now.

mepps added a comment.Jun 24 2020, 4:02 PM

So currently we're not including the unsubscribe link in the civi receipt /civicrm/admin/messageTemplates/add?action=update&id=29&reset=1

I just investigated and we will need url parameters to make this work, and to get those I'll have to write a custom civi function with a token.

@Eileenmcnaughton @Ejegg I'm going to pause on this until we talk to make sure I'm approaching it the best way.

Thanks all! In case I confused anyone, it seems like might just apply to the new "Automated Recurring Restart Email"--I wasn't sure about this myself until today.

mepps added a comment.Jun 24 2020, 4:27 PM

Thanks TSkaff!

mepps added a comment.Jun 24 2020, 8:21 PM

It looks like the acoustic emails are using a more generic link that could be put in the template.

mepps added a comment.Jun 24 2020, 8:44 PM

I can't help but notice we have two unsubscribe links. Also @DStrine there's a little confusion about whether we need to wait for more feedback before updating this?

mepps renamed this task from Missing "unsubscribe" link in auto-generated Civi emails to Missing "unsubscribe" link in automatic recurring failure email.Jun 24 2020, 8:44 PM

I think it will be a few weeks before we get new copy so we should add the link if it is easy. @CCogdill_WMF there is a direct link to acoustic unsubscribe and the fancy payments unsubscribe page. which one would you like?

Change 607817 had a related patch set uploaded (by Mepps; owner: Mepps):
[wikimedia/fundraising/crm@master] Edit recurring failed message template to include acoustic unsubscribe link

https://gerrit.wikimedia.org/r/607817

mepps added a comment.Jun 25 2020, 3:30 PM

My patch uses the acoustic link because the fancy payments one requires data about the contribution and contact. We can discuss later today. It also won't have a mailing id unless we want to create a dummy one.

I'm fine with using the Acoustic link as long as it works for y'all in
testing.

Change 607817 merged by Eileen:
[wikimedia/fundraising/crm@master] Edit recurring failed message template to include acoustic unsubscribe link

https://gerrit.wikimedia.org/r/607817

mepps closed this task as Resolved.Jul 23 2020, 3:18 PM

Confirmed that this is deployed on prod.