Page MenuHomePhabricator

Unable access to frwiki page "Spore : Aventures_galactiques"
Closed, ResolvedPublic

Description

Hello,

A problem has been reported on frwiki here.

It is no longer possible to consult frwiki page Spore : Aventures galactiques.

We get the following error message:

Le titre de la page demandée est non valide, vide, ou mal formé s’il s’agit d’un titre inter-langue ou inter-projet. Il contient peut-être un ou plusieurs caractères qui ne peuvent pas être utilisés dans les titres.

This is obviously due to an interwiki code conflict with spore: for https://wikispore.wmflabs.org/.

This article exists, it is listed in Spécial:Index/Spore.

Thank you.

(sorry for my bad English).

Other case reported with https://en.wikipedia.org/wiki/Spore:_Galactic_Adventures which can not be moved. Reported on https://meta.wikimedia.org/wiki/Talk:Interwiki_map#spore

Event Timeline

DannyS712 claimed this task.Jul 4 2020, 5:24 AM
DannyS712 triaged this task as High priority.
DannyS712 added a subscriber: DannyS712.

Yes, its removed, but the database needs to be synced. Until then, sending a manual patch to remove the entry

Restricted Application added a project: User-DannyS712. · View Herald TranscriptJul 4 2020, 5:24 AM

Change 609304 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[operations/mediawiki-config@master] Interwiki: Remove spore

https://gerrit.wikimedia.org/r/609304

Tagging as a site request since it needs to be deployed

Restricted Application added a subscriber: Dereckson. · View Herald TranscriptJul 4 2020, 5:35 AM
DannyS712 moved this task from Backlog to To deploy on the Wikimedia-Site-requests board.EditedJul 4 2020, 5:35 AM

I'll see if this can be emergency-deployed rather than waiting until monday. Just in case though, scheduled for BACON - Monday, July 06 11:00–12:00 UTC

hashar updated the task description. (Show Details)Jul 4 2020, 9:13 AM

I'll see if this can be emergency-deployed rather than waiting until monday. Just in case though, scheduled for BACON - Monday, July 06 11:00–12:00 UTC

Per @hashar in #wikimedia-operations, this doesn't warrant an emergency deployment; Will go out during backport and config on monday (@Majavah I put this before your existing patch scheduled for deployment then given the user facing impacts - hope that was okay)

hashar added a comment.Jul 4 2020, 9:26 AM

Thank you @DannyS712 for reaching out.

The issue is definitely valid but thanksfully has limited impact (it just affects articles whose title starts with Spore: (which I guess is an issue with MediaWiki itself).

Interwikis are a bit scary, I clearly remember breaking the site due to them and that part of the code is a bit too scary for a week-end deploy.

I will happily assist on Monday and added a note to myself to attend the backport and config window.

@Tractopelle-jaune Peux tu répondre sur frwiki qu'à priori ce sera corrigé Lundi? Et ton anglais est très bien :] https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:Questions_techniques/semaine_27_2020#Wikispore_et_article_commen%C3%A7ant_par_%C2%AB_Spore_:_%C2%BB

Change 609304 abandoned by DannyS712:
[operations/mediawiki-config@master] Interwiki: Remove spore

Reason:
Done by reedy in a54defff1738dc96fd82c0ebcf76019bac0b6364

https://gerrit.wikimedia.org/r/609304

DannyS712 closed this task as Resolved.Jul 4 2020, 12:44 PM
DannyS712 reassigned this task from DannyS712 to Reedy.

Reedy opted to do a full update - removing from BACON window.

hashar added a comment.Jul 4 2020, 3:45 PM

Thank you @Reedy :-]