Page MenuHomePhabricator

pwb outdated in PAWS
Closed, ResolvedPublicBUG REPORT

Description

PAWS is using the stable tag to update pywikibot. The updated code is in the stable branch.

Description was:
Title: pwb replace.py # of pages changed notification is wrong for one change

Steps to Reproduce:
Create a wiki-test-page in wiki with the attached content.


run the following (modify with your test page)

@PAWS:~$ pwb.py replace -page:user:Arjunaraoc/pwb-test-page -regex
Please enter the text that should be replaced: <nowiki/>
Please enter the new text:
Please enter another text that should be replaced,
or press Enter to start:
The summary message for the command line replacements will be something like: Bot: Automated text replacement  (-<nowiki/>+)
Press Enter to use this automatic message, or enter a description of the
changes your bot will make:

Actual Results:

Retrieving 1 pages from wikipedia:te.


>>> వాడుకరి:Arjunaraoc/pwb-test-page <<<
@@ -11 +11 @@
- #[[జల్లెడ]] పట్టి [[ఇసుక]]<nowiki/>ని తీసివెయ్యండి
+ #[[జల్లెడ]] పట్టి [[ఇసుక]]ని తీసివెయ్యండి

Do you want to accept these changes? ([y]es, [N]o, [e]dit original, edit
[l]atest, open in [b]rowser, [a]ll, [q]uit): y

0 pages changed.
@PAWS:~$

Expected Results:

Retrieving 1 pages from wikipedia:te.


>>> వాడుకరి:Arjunaraoc/pwb-test-page <<<
@@ -11 +11 @@
- #[[జల్లెడ]] పట్టి [[ఇసుక]]<nowiki/>ని తీసివెయ్యండి
+ #[[జల్లెడ]] పట్టి [[ఇసుక]]ని తీసివెయ్యండి

Do you want to accept these changes? ([y]es, [N]o, [e]dit original, edit
[l]atest, open in [b]rowser, [a]ll, [q]uit): y

1  pages changed.
@PAWS:~$

Event Timeline

Restricted Application added a project: Pywikibot. · View Herald TranscriptJul 16 2020, 9:51 AM
Restricted Application added subscribers: pywikibot-bugs-list, jeblad, Aklapper. · View Herald Transcript
Arjunaraoc renamed this task from pwb replace.py # of pages changed notification is wrong to pwb replace.py # of pages changed notification is wrong for one change.Jul 16 2020, 10:23 AM
JJMC89 updated the task description. (Show Details)Jul 16 2020, 3:29 PM

This was claimed to be solved in T147178. Please check if your environment is up-to-date.

Xqt added a subscriber: Xqt.Jul 17 2020, 1:53 PM

This was claimed to be solved in T147178. Please check if your environment is up-to-date.

Yes the script is very outdated and that bug is already solved with rPWBC33a8d56. Other improvements where made with T196851 and T171713

Currently the stable release gives:

C:\pwb\GIT\core>py pwb.py replace.py -page:user:xqt/Test A a
The summary message for the command line replacements will be something like: Bot: Automatisierte Textersetzung  (-A +a)
Press Enter to use this automatic message, or enter a description of the
changes your bot will make:
Retrieving 1 pages from wikipedia:de.


>>> Benutzer:Xqt/Test <<<
@@ -1 +1 @@
- <code>&Amp;</code>
+ <code>&amp;</code>

Do you want to accept these changes? ([y]es, [N]o, [e]dit original, edit
[l]atest, open in [b]rowser, [m]ore context, [a]ll, [q]uit): y
Edit summary: Bot: Automatisierte Textersetzung  (-A +a)

1 pages read
1 pages written
0 pages skipped
Execution time: 6 seconds
Read operation time: 4.0 seconds
Write operation time: 6.0 seconds
Script terminated successfully.

Did PAWS install outdated stable release?

Chicocvenancio added a project: PAWS.

Did PAWS install outdated stable release?

Seems like. Investigating.

There seems to be a stable tag in pywikibot pointing at rPWBC71e36c1574454d9438deaac08754ee4484dc4797 and a stable branch currently at rPWBCb8358a38b41be7f0d32c0e5178d69a7f555c2563.

I'm moving the updating to the branch.

Chicocvenancio renamed this task from pwb replace.py # of pages changed notification is wrong for one change to pwb Outadated in PAWS.Jul 18 2020, 2:05 PM
Chicocvenancio triaged this task as Medium priority.
Chicocvenancio updated the task description. (Show Details)
Chicocvenancio added a comment.EditedJul 18 2020, 2:11 PM

@Arjunaraoc The fix will probably be merged in a couple of days. In the meantime, if you want a workaround you can manually update pywikibot by:

cd /srv/paws/pwb && git pull origin stable
Aklapper renamed this task from pwb Outadated in PAWS to pwb outdated in PAWS.Jul 18 2020, 2:39 PM
Xqt added a comment.Jul 19 2020, 4:36 AM

There seems to be a stable tag in pywikibot pointing at rPWBC71e36c1574454d9438deaac08754ee4484dc4797 and a stable branch currently at rPWBCb8358a38b41be7f0d32c0e5178d69a7f555c2563.

I'm moving the updating to the branch.

The repository at gerrit does not have a stable tag anymore https://gerrit.wikimedia.org/r/admin/repos/pywikibot%252Fcore,tags,25
Is there sth. out of sync?

Mentioned in SAL (#wikimedia-cloud) [2020-07-21T15:13:54Z] <chicocvenancio> merge pr #50 to fix T258142

Chicocvenancio closed this task as Resolved.Jul 21 2020, 3:19 PM

The repository at gerrit does not have a stable tag anymore https://gerrit.wikimedia.org/r/admin/repos/pywikibot%252Fcore,tags,25
Is there sth. out of sync?

The image is out of sync from the repo. The way to sync it is defined in https://github.com/toolforge/paws/blob/deed4c534ac1e2a6413bfcef97d421825c99b491/paws/values.yaml#L133 and is run on every server startup. If the tag was there when the image was built it will still be there until we rebuild the image, and that is not often done.

deed4c534ac1e2a6413bfcef97d421825c99b491 has been merged, PAWS' PWB is now at 4570e1f8

@PAWS:/srv/paws/pwb$ git log --oneline
4570e1f8 (HEAD, origin/stable) Update git submodules