Page MenuHomePhabricator

[mobile] HomepageModule does not record link-click events for Impact module
Closed, ResolvedPublic

Description

Note1: This task is for additional checking - given the limitation of betalabs eventlogging, it might be not an issue in production.
Note2: On mobile the link-click happens on the second second screen.

Checking actions for Impact module on Special:Homepage (the testing was done on cswiki betalabs) it seems that for mobile the only actions recorded in eventlogging were imrpession and close, i.e.

event.HomepageModule 
{action: "impression", action_data: "", user_id: 54, user_editcount: 6, module: "impact", …}
action: "impression"
action_data: ""
homepage_pageview_token: "bgklh8b2gprcg8a72gfk78s4su142k38"
is_mobile: true
mode: "mobile-overlay"
module: "impact"
state: "activated"
user_editcount: 6
user_id: 54

event.HomepageModule 
{action: "close", action_data: "", user_id: 54, user_editcount: 6, module: "impact", …}
action: "close"
action_data: ""
homepage_pageview_token: "40bup51uqfb9cjt58sur99kvk06f4euk"
is_mobile: true
mode: "mobile-overlay"
module: "impact"
state: "activated"
user_editcount: 6
user_id: 54

For desktop all of the following link-click related events were recorded:

action: "link-click"action_data: "linkId=impact-article-title"
action: "link-click""linkId=impact-pageviews"
action: "link-click""linkId=impact-contributions"

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 7 2020, 12:42 AM

EventLogging on the beta cluster appears to be broken enough that it's near impossible to verify events there, unfortunately. From what I could tell by checking the JS console in my browser, link-click events on desktop trigger an event, but I didn't see any of those on mobile.

I also had a look at the data in the Data Lake, and there are very few mobile link-click events stored there, single digits per day across all wikis. I also tested on cswiki in production and monitored the events through Kafka, and could verify the impression and close events flowing in, but again did not see any link-click events after clicking a link in the impact module.

Thanks for checking this out, @Etonkovidova and @nettrom_WMF. I see the same thing. I'm putting this into Ready for Development.

Change 619392 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Homepage: Fix link-click logging on mobile

https://gerrit.wikimedia.org/r/619392

Change 619392 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Homepage: Fix link-click logging on mobile

https://gerrit.wikimedia.org/r/619392

Moving to PM review - no issues found; checked in betalabs - all link-click events are recorded on mobile.

Etonkovidova added a comment.EditedAug 21 2020, 6:41 PM

@MMiller_WMF, @nettrom_WMF - I do not see link-click events recorded if the clicked links were opened in a different tab/window. It's not based on just the Console observations - there is no records in /srv/log/eventlogging/all-event.log. Is it a known issue?

Re-checked - the issue is present for any link on the Homepage. As @Catrope suggests - filed as T261173: Homepage - link-click events not recorded when links opened in a different tab/window

MMiller_WMF closed this task as Resolved.Sep 1 2020, 11:59 PM

Thank you!