Page MenuHomePhabricator

Compare the contents: Use a loading indicator while getting the article contents
Closed, ResolvedPublic

Description

As part of the "Compare " step (T241589) of the section translation workflow, users access the selected source section and the article in the target language.

While those are loaded we want to show the user the standard loading indicator:

Compare contents - Contents Dimensions.png (768×1 px, 160 KB)

More details are available in the parent task: T241589: Section Translation: Compare the contents before translating

Event Timeline

Pginer-WMF created this task.
Pginer-WMF moved this task from Backlog to Core workflow on the SectionTranslation board.
Jpita added a subscriber: Jpita.

If you note on this gif, on the right bottom side, a blue "translate" button appears and then disappears.
Why is this button there? Can we remove it?

Large GIF (376x124).gif (124×376 px, 211 KB)

If you note on this gif, on the right bottom side, a blue "translate" button appears and then disappears.
Why is this button there? Can we remove it?

Large GIF (376x124).gif (124×376 px, 211 KB)

I have the impression that the view is loaded for an initial status that changes as data becomes ready producing this glitch. So the issue may be more general (related to our approach for loading and waiting) than just about this specific button.

So is this fixable on this ticket or not?

So is this fixable on this ticket or not?

@ngkountas can you confirm whether this is a general issue with the approach or a specific issue of this step?
If it is a general issue we can create a follow-up ticket to make sure that this kind of glitch does not happen in any step.

This is a specific issue of this step and doesn't affect other screens. Follow-up ticket has been created: https://phabricator.wikimedia.org/T263118

This is a specific issue of this step and doesn't affect other screens. Follow-up ticket has been created: https://phabricator.wikimedia.org/T263118

Perfect. Thanks!