Page MenuHomePhabricator

Page content service renders Graph:Chart with spurious '\n'
Closed, InvalidPublic

Description

Steps to reproduce

  1. Visit https://en.wikipedia.org/api/rest_v1/page/mobile-html/COVID-19_pandemic_in_India
  2. Scroll down to the "Statistics" section.
  3. Scroll a little more to observe the spurious '\n' after each graph

Expected results

No spurious '\n' is observed after each graph.

Screenshot

Environments details

Device: Samsung Galaxy J111F
Android version: 5.1.1
Wikipedia app version: 2.7.50331-alpha-2020-09-16

NOTE: Tagging the Android app as that is where I initially observed this. Also, I didn't observe such behaviour in the desktop and mobile websites.

Event Timeline

Kaartic created this task.Wed, Sep 16, 6:09 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Kaartic updated the task description. (Show Details)Wed, Sep 16, 6:11 PM

I did a bit of triaging on the issue. \n doesn't show up neither in mobile-html [1] nor in the alpha version of the android app even using an article revision older than the report date.

[1] https://en.wikipedia.org/api/rest_v1/page/mobile-html/COVID-19_pandemic_in_India

@Kaartic can you still reproduce this issue with your device?

This doesn't appear for me, either. I suspect that it was an issue introduced temporarily by a template or Parsoid change which has since been resolved.

Kaartic closed this task as Invalid.EditedFri, Sep 25, 4:40 AM

@Kaartic can you still reproduce this issue with your device?

Nope. I could no longer reproduce this myself. Thanks!