Page MenuHomePhabricator

Add all people who have voted on a Bugzilla ticket to the Subscribers (CC) list of the corresponding ticket in Maniphest
Closed, DeclinedPublic

Description

Add all people who have voted on a Bugzilla ticket to the Subscribers (CC) list of the corresponding ticket in Maniphest.

From T423#17.

Details

Reference
fl432

Event Timeline

flimport raised the priority of this task from to Normal.Sep 12 2014, 1:40 AM
flimport set Reference to fl432.

qgil wrote on 2014-07-11 14:03:56 (UTC)

Just checking. In order to CC Bugzilla users to Phabricator tasks, those old users must exist as new users in Phabricator during the migration process. @Rush, does this factor fit in your idea of how Bugzilla users would be created/claimed in Phabricator?

Rush wrote on 2014-07-11 14:07:57 (UTC)

I think yes, but voting in the New Phab World Order we are thinking is more akin to awarding a token (pleased/displeased) while cc'ing comes with notifications and it being in the mix for your dashboards and such. I don't know if we can automate token giving via api, but are we sure vote => cc is what we want?

@Aklapper?

aklapper wrote on 2014-07-14 11:25:15 (UTC)

are we sure vote => cc is what we want?

We don't have any data which interpretations and motivations for voting on a bug report in Bugzilla are the most common ones (and I am not aware of any literature on this topic either).

Personally I lean towards not automatically turning votes into CC'ing people when migrating from Bugzilla to Phabricator - if people wanted to be CC'ed, they could have CC'ed themselves in addition to voting (and I think if you already managed to cope with Bugzilla's horrible Voting UI then CC'ing yourself should have been a smaller challenge).

qgil wrote on 2014-07-14 12:51:08 (UTC)

I just realized that votng in Bugzilla doesn't add you to the CC list. Therefore I agree, voters in Bugzilla shouldn't be converted to CCed in Phabricator.

aklapper wrote on 2014-07-14 14:03:20 (UTC)

In T432#13, @Qgil wrote:

I just realized that votng in Bugzilla doesn't add you to the CC list.

The problem is that https://bugzilla.wikimedia.org/userprefs.cgi?tab=email by default has some checkboxes enabled for "When my relationship to this bug is Voter, I want to receive mail when ..."

I wonder if it's worth to run a SQL query to check which settings are common among people.

Rush wrote on 2014-07-16 17:24:14 (UTC)

I think we decided not to add previous voters to CC. Previous voters info (if available from bz api will be added as metadata).

resolving, @Aklapper final comment?

aklapper wrote on 2014-07-16 20:09:51 (UTC)

Yes (though I'm not sure that "Resolved" is better than "Wontfix").

No matter what, some people will be unhappy. In this case if I can choose between some people slightly interested in a ticket but not CCed on it vs. some people suddenly getting spammed with bugmail, I prefer to not spam.

aklapper wrote on 2014-07-18 10:05:37 (UTC)

Bleh. I didn't want to reopen this.

aklapper wrote on 2014-08-12 17:30:52 (UTC)

And just for the records and to document it: We cannot export votes via Bugzilla's API. http://www.bugzilla.org/docs/4.4/en/html/api/Bugzilla/WebService/Bug.html says "Searching by votes was removed in Bugzilla 4.0.", reference: https://bugzilla.mozilla.org/show_bug.cgi?id=577049

importing issue status

flimport closed this task as Declined.Sep 12 2014, 1:41 AM
flimport added a subscriber: chasemp.
He7d3r added a subscriber: He7d3r.Oct 24 2014, 11:04 AM