Page MenuHomePhabricator

No "Languages" section visible in the sidebar of the "Modern" skin
Closed, ResolvedPublic

Description

This morning I noticed I can no longer see the interwiki links on the sidebar. I'm fairly sure they were there yesterday. I took this to the helpdesk and other users confirmed that it seems only to be affecting the "Modern" skin.

Event Timeline

Deb created this task.Oct 16 2020, 5:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 16 2020, 5:25 PM
Aklapper changed the task status from Open to Stalled.Oct 16 2020, 5:30 PM

Hi @Deb, thanks for taking the time to report this and welcome to Wikimedia Phabricator!

Unfortunately this Wikimedia Phabricator task lacks some information, for example which website this is about.
If you have time and can still reproduce the situation: Please add a more complete description to this task. Thanks!

Deb added a comment.Oct 16 2020, 6:14 PM

The interwiki links aren't appearing on the sidebar in the "Modern" skin in en.wikipedia.org articles. I believe that they are still present in other language Wikipedias. This change seems to have happened on 15-16 October 2020. See below the copied conversation from the helpdesk.

This is probably a dumb question and I've probably missed a discussion - why can I no longer see the interwiki links at the side of the page? They were there yesterday, under the toolbar. [[User:Deb|Deb]] ([[User talk:Deb|talk]]) 07:35, 16 October 2020 (UTC)
:I don't know. For me they appear both in the new vector version and timeless. Is there any particular page you think about and which skin are you using? [[User:Victor Schmidt mobil|Victor Schmidt mobil]] ([[User talk:Victor Schmidt mobil|talk]]) 07:49, 16 October 2020 (UTC)
:(ec) {{u|Deb}} They were there on this Help desk on my browser just before I clicked edit. They don't appear while I am in editing mode. —[[User:teb728|teb728]] [[User talk:teb728|t]] [[Special:Contributions/teb728|c]] 07:48, 16 October 2020 (UTC)
::They never appear in edit mode, but now they aren't there at all - yet they are there in all other Wikipedias. Surely my profile should be the same in French wikipedia as it is in English wikipedia? I've changed nothing and I'm using Modern, but I can see that they are still there in the Timeless skin so I guess there must have been a change to that. [[User:Deb|Deb]] ([[User talk:Deb|talk]]) 12:47, 16 October 2020 (UTC)
:::I momentarily switched over to that skin to test it out and I can confirm that the interwiki links don't appear in the sidebar. It sounds like a [[WP:VPT]] or Phabricator issue. —[[User:Tenryuu|<span style="color:#556B2F">Tenryuu&nbsp;🐲</span>]]&nbsp;(&nbsp;[[User talk:Tenryuu|💬]]&nbsp;•&nbsp;[[Special:Contributions/Tenryuu|📝]]&nbsp;) 15:41, 16 October 2020 (UTC)

Soda added a subscriber: Soda.

This report seems to be about the fact that the Languages section has vanished/is not visible in the Modern skin. Reproducible at this link (Observe the lack of the languages section in the sidebar as compared to the Vector skin).

Aklapper renamed this task from Sidebar not working in "Modern" skin to No "Languages" section visible in the sidebar of the "Modern" skin.Oct 16 2020, 6:19 PM
Aklapper changed the task status from Stalled to Open.

Change 634589 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/Modern@master] Restore languages to Modern skin

https://gerrit.wikimedia.org/r/634589

Change 634589 merged by jenkins-bot:
[mediawiki/skins/Modern@master] Restore languages to Modern skin

https://gerrit.wikimedia.org/r/634589

Jdlrobson closed this task as Resolved.Oct 19 2020, 5:00 PM
Jdlrobson claimed this task.

The languages are now showing again https://en.wikipedia.beta.wmflabs.org/wiki/Main_Page?useskin=modern
Will be fixed on Thursday.
No backport as Modern is a low used and not an actively supported skin.