Page MenuHomePhabricator

"--release is not implemented for --backend=kubernetes" with latest tools-webservice from Git
Closed, ResolvedPublic

Description

Noticed this while testing other tools-webservice changes - after some changes to allow choosing between the buster and stretch grids, it's no longer possible to interact with kubernetes based webservices, as the release flag has a default value this check always complains about it even when it's the default and not set explicitly.

Event Timeline

Change 692263 had a related patch set uploaded (by Arturo Borrero Gonzalez; author: Arturo Borrero Gonzalez):

[operations/software/tools-webservice@master] scripts/webservice: don't check for the release arg in k8s backend

https://gerrit.wikimedia.org/r/692263

Change 692263 merged by jenkins-bot:

[operations/software/tools-webservice@master] scripts/webservice: don't check for the release arg in k8s backend

https://gerrit.wikimedia.org/r/692263

Majavah assigned this task to aborrero.