Page MenuHomePhabricator

Wikidata Query Service inaccessible via GUI, only partially accessible via embedded queries
Closed, ResolvedPublicBUG REPORT

Description

When trying to access https://query.wikidata.org/ , I am currently getting the directory listing rather than the expected GUI

Screen Shot 2021-09-08 at 02.19.59.png (1×1 px, 374 KB)
. Likewise, saved queries like this or that do not work.

This also affects embedded queries as in the Scholia example, of which I am adding a current screenshot too (a more detailed one sits here).

Screen Shot 2021-09-08 at 02.08.31.png (1×2 px, 206 KB)

Event Timeline

Daniel_Mietchen triaged this task as Unbreak Now! priority.Wed, Sep 8, 6:36 AM

@Lydia_Pintscher Thanks this is definitely related to that work. When I spot-checked query.wikidata.org after merging earlier it looks like the new config hadn't taken effect yet thus why things initially looked okay.

Reverted the puppet change. Working on getting things back how they should be currently.

(Thanks for opening this @Daniel_Mietchen)

Config change was successfully reverted. We had to clear out the varnish cache with echo 'https://query.wikidata.org/' | mwscript purgeList.php per https://wikitech.wikimedia.org/wiki/Kafka_HTTP_purging.

Everything should be / is back to normal now.

dcausse assigned this task to RKemper.
dcausse moved this task from Incoming to Needs Reporting on the Discovery-Search (Current work) board.
dcausse added a subscriber: dcausse.

Closing, the UI should be accessible again.

Yes, seems to be back to normal. Thanks all!

For the record, it seems that reverting change that restored the operation of the site has been: https://gerrit.wikimedia.org/r/c/operations/puppet/+/719185